低危 Apache ActiveMQ 至 5.10.0 LDAPLoginModule 凭证管理漏洞

CVE编号

CVE-2015-6524

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-08-25
漏洞描述
Apache ActiveMQ是美国阿帕奇(Apache)软件基金会所研发的一套开源的消息中间件,它支持Java消息服务、集群、Spring Framework等。

Apache ActiveMQ 5.10.1之前5.x版本的Java Authentication and Authorization Service(JAAS)中的LDAPLoginModule实现过程中存在安全漏洞,该漏洞源于程序允许用户名中存在通配符。远程攻击者可通过实施暴力破解攻击利用该漏洞获取证书。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://activemq.apache.org/security-advisories.data/CVE-2014-3612-announcement.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache activemq 5.0.0 -
运行在以下环境
应用 apache activemq 5.1.0 -
运行在以下环境
应用 apache activemq 5.10.0 -
运行在以下环境
应用 apache activemq 5.2.0 -
运行在以下环境
应用 apache activemq 5.3.0 -
运行在以下环境
应用 apache activemq 5.3.1 -
运行在以下环境
应用 apache activemq 5.3.2 -
运行在以下环境
应用 apache activemq 5.4.0 -
运行在以下环境
应用 apache activemq 5.4.1 -
运行在以下环境
应用 apache activemq 5.4.2 -
运行在以下环境
应用 apache activemq 5.4.3 -
运行在以下环境
应用 apache activemq 5.5.0 -
运行在以下环境
应用 apache activemq 5.5.1 -
运行在以下环境
应用 apache activemq 5.6.0 -
运行在以下环境
应用 apache activemq 5.7.0 -
运行在以下环境
应用 apache activemq 5.8.0 -
运行在以下环境
应用 apache activemq 5.9.0 -
运行在以下环境
应用 apache activemq 5.9.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.0+dfsg1-4
运行在以下环境
系统 debian_7 activemq * Up to
(excluding)
5.6.0+dfsg-1+deb7u1
运行在以下环境
系统 fedoraproject fedora 22 -
运行在以下环境
系统 fedoraproject fedora 23 -
运行在以下环境
系统 fedora_22 activemq * Up to
(excluding)
5.6.0-12.fc22
运行在以下环境
系统 fedora_23 activemq * Up to
(excluding)
5.6.0-12.fc23
运行在以下环境
系统 ubuntu_14.04_lts activemq * Up to
(excluding)
5.6.0+dfsg-1+deb7u1build0.14.04.1
运行在以下环境
系统 ubuntu_16.04_lts activemq * Up to
(excluding)
5.13.2+dfsg-2
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    N/A
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况