中危 FFmpeg up to 2.7.1 pthread_frame.c ff_frame_thread_init 拒绝服务漏洞

CVE编号

CVE-2015-6825

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-09-06
漏洞描述
FFmpeg是FFmpeg团队的一套可录制、转换以及流化音视频的完整解决方案。

FFmpeg 2.7.2之前版本的libavcodec/pthread_frame.c文件中的‘ff_frame_thread_init’函数存在安全漏洞,该漏洞源于程序未能正确处理内存分配失败。远程攻击者可借助特制的文件利用该漏洞造成拒绝服务(无效的指针访问)。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=3197c0aa87a3b7190e17d49e6fbc7b554e4b3f0a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ffmpeg ffmpeg * Up to
(including)
2.7.1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 debian_8 libav * Up to
(excluding)
6:11.4-1~deb8u1
运行在以下环境
系统 ubuntu_16.04.7_lts ffmpeg * Up to
(excluding)
7:2.8.3-1
运行在以下环境
系统 ubuntu_18.04.5_lts ffmpeg * Up to
(excluding)
7:2.8.3-1
阿里云评分
5.0
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况