低危 gdk-pixbuf 2.30.x gdk-pixbuf-scale.c gdk_pixbuf_flip 内存破坏漏洞

CVE编号

CVE-2015-7552

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-04-19
漏洞描述
gdk-pixbuf是一个用于图像加载和像素缓冲处理的工具包。

gdk-pixbuf中存在安全漏洞,该漏洞源于gdk-pixbuf-scale.c文件中的‘gdk_pixbuf_flip()’函数中存在错误。攻击者可利用该漏洞造成拒绝服务,或控制使用库的应用程序。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://www.suse.com/support/update/announcement/2016/suse-su-20160225-1.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.32.0-1
运行在以下环境
系统 debian_7 gdk-pixbuf * Up to
(excluding)
2.26.1-1+deb7u5
运行在以下环境
系统 debian_8 gdk-pixbuf * Up to
(excluding)
2.31.1-2+deb8u4
运行在以下环境
系统 fedora_30 gdk-pixbuf * Up to
(excluding)
2.36.12-1.fc30
运行在以下环境
系统 fedora_31 gdk-pixbuf * Up to
(excluding)
2.40.0-1.fc31
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_13.2 gdk-pixbuf * Up to
(excluding)
2.31.6-6.1
运行在以下环境
系统 opensuse_Leap_42.1 gdk-pixbuf * Up to
(excluding)
2.31.6-4.1
运行在以下环境
系统 redhat_7 at-spi2-core * Up to
(excluding)
0:2.22.0-1.el7
运行在以下环境
系统 sles_11_SP3 gdk-pixbuf * Up to
(excluding)
2.18.9-0.39.1
运行在以下环境
系统 sles_11_SP4 gdk-pixbuf * Up to
(excluding)
2.18.9-0.39.1
运行在以下环境
系统 sles_12 gdk-pixbuf * Up to
(excluding)
2.30.6-10.1
运行在以下环境
系统 sles_12 gdk-pixbuf-lang * Up to
(excluding)
2.34.0-16
运行在以下环境
系统 sles_12_SP1 gdk-pixbuf * Up to
(excluding)
2.30.6-10.1
运行在以下环境
系统 suse_11_SP3 gdk-pixbuf * Up to
(excluding)
2.18.9-0.39.1
运行在以下环境
系统 suse_11_SP4 gdk-pixbuf * Up to
(excluding)
2.18.9-0.39.1
运行在以下环境
系统 suse_12 gdk-pixbuf * Up to
(excluding)
2.30.6-10.1
运行在以下环境
系统 suse_12_SP1 gdk-pixbuf * Up to
(excluding)
2.30.6-10.1
运行在以下环境
系统 ubuntu_12.04.5_lts gdk-pixbuf * Up to
(excluding)
2.26.1-1ubuntu1.5
运行在以下环境
系统 ubuntu_12.04_lts gdk-pixbuf * Up to
(excluding)
2.26.1-1ubuntu1.5
运行在以下环境
系统 ubuntu_14.04.6_lts gdk-pixbuf * Up to
(excluding)
2.30.7-0ubuntu1.6
运行在以下环境
系统 ubuntu_14.04_lts gdk-pixbuf * Up to
(excluding)
2.30.7-0ubuntu1.6
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况