低危 ntpd 4.2.8 decodenetnum 拒绝服务漏洞

CVE编号

CVE-2015-7855

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-08
漏洞描述
ntpd中的decodenetnum函数在4.2.8p4之前的NTP 4.2.x和4.3.77之前的4.3.x中允许远程攻击者通过包含长数据值的6或模式7数据包导致拒绝服务(断言失败)。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://support.ntp.org/bin/view/Main/NtpBug2922
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp oncommand_balance - -
运行在以下环境
应用 netapp oncommand_performance_manager - -
运行在以下环境
应用 netapp oncommand_unified_manager - -
运行在以下环境
应用 ntp ntp * From
(including)
4.2.0
Up to
(excluding)
4.2.8
运行在以下环境
应用 ntp ntp * From
(including)
4.3.0
Up to
(excluding)
4.3.77
运行在以下环境
应用 ntp ntp 4.2.8 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:4.2.8p4+dfsg-1
运行在以下环境
系统 debian_6 ntp * Up to
(excluding)
1:4.2.6.p2+dfsg-1+deb6u4
运行在以下环境
系统 debian_7 ntp * Up to
(excluding)
1:4.2.6.p5+dfsg-2+deb7u6
运行在以下环境
系统 debian_8 ntp * Up to
(excluding)
1:4.2.6.p5+dfsg-7+deb8u1
运行在以下环境
系统 opensuse_13.2 ntp * Up to
(excluding)
4.2.8p7-25.15.1
运行在以下环境
系统 opensuse_Leap_42.1 ntp * Up to
(excluding)
4.2.8p4-9.2
运行在以下环境
系统 suse_11_SP4 ntp * Up to
(excluding)
4.2.8p4-5.1
运行在以下环境
系统 suse_12 ntp * Up to
(excluding)
4.2.8p6-46.5.2
运行在以下环境
系统 ubuntu_12.04.5_lts ntp * Up to
(excluding)
1:4.2.6.p3+dfsg-1ubuntu3.6
运行在以下环境
系统 ubuntu_14.04 ntp * Up to
(excluding)
1:4.2.6.p5+dfsg-3ubuntu2.14.04.5
运行在以下环境
系统 ubuntu_14.04.6_lts ntp * Up to
(excluding)
1:4.2.6.p5+dfsg-3ubuntu2.14.04.5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况