中危 Cyrus IMAP index_urlfetch整数溢出漏洞(CNVD-2015-07903)

CVE编号

CVE-2015-8078

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-12-04
漏洞描述
Cyrus IMAP服务器是卡耐基梅隆大学开发的电子邮件服务器。

Cyrus IMAP 2.3.19, 2.4.18, 2.5.6版本imap/index.c中的函数index_urlfetch存在整数溢出漏洞,远程攻击者通过urlfetch范围检查及section_offset变量相关矢量,利用此漏洞可执行非法操作。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://docs.cyrus.foundation/imap/release-notes/2.5/x/2.5.7.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 cyrus imap 2.3.0 -
运行在以下环境
应用 cyrus imap 2.3.1 -
运行在以下环境
应用 cyrus imap 2.3.10 -
运行在以下环境
应用 cyrus imap 2.3.11 -
运行在以下环境
应用 cyrus imap 2.3.12 -
运行在以下环境
应用 cyrus imap 2.3.13 -
运行在以下环境
应用 cyrus imap 2.3.14 -
运行在以下环境
应用 cyrus imap 2.3.15 -
运行在以下环境
应用 cyrus imap 2.3.16 -
运行在以下环境
应用 cyrus imap 2.3.17 -
运行在以下环境
应用 cyrus imap 2.3.18 -
运行在以下环境
应用 cyrus imap 2.3.2 -
运行在以下环境
应用 cyrus imap 2.3.3 -
运行在以下环境
应用 cyrus imap 2.3.4 -
运行在以下环境
应用 cyrus imap 2.3.5 -
运行在以下环境
应用 cyrus imap 2.3.6 -
运行在以下环境
应用 cyrus imap 2.3.7 -
运行在以下环境
应用 cyrus imap 2.3.8 -
运行在以下环境
应用 cyrus imap 2.3.9 -
运行在以下环境
应用 cyrus imap 2.4.0 -
运行在以下环境
应用 cyrus imap 2.4.1 -
运行在以下环境
应用 cyrus imap 2.4.10 -
运行在以下环境
应用 cyrus imap 2.4.11 -
运行在以下环境
应用 cyrus imap 2.4.12 -
运行在以下环境
应用 cyrus imap 2.4.13 -
运行在以下环境
应用 cyrus imap 2.4.14 -
运行在以下环境
应用 cyrus imap 2.4.15 -
运行在以下环境
应用 cyrus imap 2.4.16 -
运行在以下环境
应用 cyrus imap 2.4.17 -
运行在以下环境
应用 cyrus imap 2.4.2 -
运行在以下环境
应用 cyrus imap 2.4.3 -
运行在以下环境
应用 cyrus imap 2.4.4 -
运行在以下环境
应用 cyrus imap 2.4.5 -
运行在以下环境
应用 cyrus imap 2.4.6 -
运行在以下环境
应用 cyrus imap 2.4.7 -
运行在以下环境
应用 cyrus imap 2.4.8 -
运行在以下环境
应用 cyrus imap 2.4.9 -
运行在以下环境
应用 cyrus imap 2.5.0 -
运行在以下环境
应用 cyrus imap 2.5.1 -
运行在以下环境
应用 cyrus imap 2.5.2 -
运行在以下环境
应用 cyrus imap 2.5.3 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_Leap_42.1 cyrus-imapd * Up to
(excluding)
2.4.18-3.1
运行在以下环境
系统 opensuse_Leap_42.1 perl-Cyrus-IMAP * Up to
(excluding)
2.4.18-3.1
运行在以下环境
系统 opensuse_Leap_42.1 perl-Cyrus-SIEVE-managesieve * Up to
(excluding)
2.4.18-3.1
运行在以下环境
系统 sles_11_SP4 cyrus-imapd * Up to
(excluding)
2.3.11-60.65.67.1
运行在以下环境
系统 sles_11_SP4 perl-Cyrus-IMAP * Up to
(excluding)
2.3.11-60.65.67.1
运行在以下环境
系统 sles_11_SP4 perl-Cyrus-SIEVE-managesieve * Up to
(excluding)
2.3.11-60.65.67.1
运行在以下环境
系统 sles_12 cyrus-imapd * Up to
(excluding)
2.3.18-37
运行在以下环境
系统 sles_12 cyrus-imapd * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 sles_12 perl-Cyrus-IMAP * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 sles_12 perl-Cyrus-SIEVE-managesieve * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 sles_12_SP1 cyrus-imapd * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 sles_12_SP1 perl-Cyrus-IMAP * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 sles_12_SP1 perl-Cyrus-SIEVE-managesieve * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 suse_11_SP4 cyrus-imapd * Up to
(excluding)
2.3.11-60.65.67.1
运行在以下环境
系统 suse_12 cyrus-imapd * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 suse_12_SP1 cyrus-imapd * Up to
(excluding)
2.3.18-37.1
运行在以下环境
系统 ubuntu_18.04.5_lts cyrus-imapd * Up to
(excluding)
2.5.8-1
运行在以下环境
系统 ubuntu_18.04_lts cyrus-imapd * Up to
(excluding)
2.5.8-1
运行在以下环境
系统 ubuntu_18.10 cyrus-imapd * Up to
(excluding)
2.5.8-1
阿里云评分
6.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-189 数值错误
阿里云安全产品覆盖情况