GNU a2ps格式化字符串拒绝服务漏洞

CVE编号

CVE-2015-8107

利用情况

暂无

补丁情况

N/A

披露时间

2017-04-14
漏洞描述
GNU a2ps是GNU计划开发的一款支持将任何类型的文件转换为PostScript文件的软件包。

GNU a2ps formatted-printing函数未能充分过滤作为格式化说明符的用户输入,允许攻击者利用该漏洞构建恶意文件,诱使应用解析,可使应用程序崩溃。
解决建议
目前没有详细解决方案提供:
http://www.gnu.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu a2ps 4.14 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:4.14-1.2
运行在以下环境
系统 ubuntu_14.04_lts a2ps * Up to
(excluding)
1:4.14-1.3
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-134 使用外部控制的格式字符串
阿里云安全产品覆盖情况