低危 XenSource Xen 4.3.x/4.4.x/4.5.x/4.6.x Error XENMEM_exchange 拒绝服务漏洞

CVE编号

CVE-2015-8339

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-12-18
漏洞描述
Xen是英国剑桥大学开发的一款开源的虚拟机监视器产品。

Xen common/memory.c文件中的'memory_exchange'函数未能正确处理域的返回页面,允许本地攻击者利用该漏洞使应用程序崩溃。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://xenbits.xen.org/xsa/advisory-159.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.8.0~rc3-1
运行在以下环境
系统 debian_10 xen * Up to
(excluding)
4.8.0~rc3-1
运行在以下环境
系统 debian_11 xen * Up to
(excluding)
4.8.0~rc3-1
运行在以下环境
系统 debian_12 xen * Up to
(excluding)
4.8.0~rc3-1
运行在以下环境
系统 debian_7 xen * Up to
(excluding)
4.1.6.1-1+deb7u1
运行在以下环境
系统 debian_8 xen * Up to
(excluding)
4.4.1-9+deb8u3
运行在以下环境
系统 fedora_22 xen-hypervisor * Up to
(excluding)
4.5.2-5.fc22
运行在以下环境
系统 fedora_23 xen-hypervisor * Up to
(excluding)
4.5.2-5.fc23
运行在以下环境
系统 opensuse_13.1 xen-libs-debuginfo-32bit * Up to
(excluding)
4.3.4_10-53.1
运行在以下环境
系统 opensuse_13.2 xen-tools-domU * Up to
(excluding)
4.4.3_08-36.1
运行在以下环境
系统 opensuse_Leap_42.1 xen-libs-32bit * Up to
(excluding)
4.5.2_04-9.2
运行在以下环境
系统 suse_11_SP3 xen * Up to
(excluding)
4.2.5_18-21.1
运行在以下环境
系统 suse_11_SP4 xen * Up to
(excluding)
4.4.3_06-29.1
运行在以下环境
系统 suse_12 xen * Up to
(excluding)
4.4.3_06-22.15.1
运行在以下环境
系统 suse_12_SP1 xen * Up to
(excluding)
4.5.2_02-4.1
运行在以下环境
系统 ubuntu_12.04.5_lts xen * Up to
(excluding)
4.1.6.1-0ubuntu0.12.04.8
运行在以下环境
系统 ubuntu_14.04.6_lts xen * Up to
(excluding)
4.4.2-0ubuntu0.14.04.4
运行在以下环境
系统 ubuntu_16.04 xen * Up to
(excluding)
4.6.0-1ubuntu2
运行在以下环境
系统 xen xen 3.2.0 -
运行在以下环境
系统 xen xen 3.2.1 -
运行在以下环境
系统 xen xen 3.2.2 -
运行在以下环境
系统 xen xen 3.2.3 -
运行在以下环境
系统 xen xen 3.3.0 -
运行在以下环境
系统 xen xen 3.3.1 -
运行在以下环境
系统 xen xen 3.3.2 -
运行在以下环境
系统 xen xen 3.4.0 -
运行在以下环境
系统 xen xen 3.4.1 -
运行在以下环境
系统 xen xen 3.4.2 -
运行在以下环境
系统 xen xen 3.4.3 -
运行在以下环境
系统 xen xen 3.4.4 -
运行在以下环境
系统 xen xen 4.0.0 -
运行在以下环境
系统 xen xen 4.0.1 -
运行在以下环境
系统 xen xen 4.0.2 -
运行在以下环境
系统 xen xen 4.0.3 -
运行在以下环境
系统 xen xen 4.0.4 -
运行在以下环境
系统 xen xen 4.1.0 -
运行在以下环境
系统 xen xen 4.1.1 -
运行在以下环境
系统 xen xen 4.1.2 -
运行在以下环境
系统 xen xen 4.1.3 -
运行在以下环境
系统 xen xen 4.1.4 -
运行在以下环境
系统 xen xen 4.1.5 -
运行在以下环境
系统 xen xen 4.1.6 -
运行在以下环境
系统 xen xen 4.1.6.1 -
运行在以下环境
系统 xen xen 4.2.0 -
运行在以下环境
系统 xen xen 4.2.1 -
运行在以下环境
系统 xen xen 4.2.2 -
运行在以下环境
系统 xen xen 4.2.3 -
运行在以下环境
系统 xen xen 4.2.4 -
运行在以下环境
系统 xen xen 4.2.5 -
运行在以下环境
系统 xen xen 4.3.0 -
运行在以下环境
系统 xen xen 4.3.1 -
运行在以下环境
系统 xen xen 4.3.2 -
运行在以下环境
系统 xen xen 4.3.3 -
运行在以下环境
系统 xen xen 4.3.4 -
运行在以下环境
系统 xen xen 4.4.0 -
运行在以下环境
系统 xen xen 4.4.1 -
运行在以下环境
系统 xen xen 4.4.2 -
运行在以下环境
系统 xen xen 4.4.3 -
运行在以下环境
系统 xen xen 4.5.0 -
运行在以下环境
系统 xen xen 4.5.1 -
运行在以下环境
系统 xen xen 4.5.2 -
运行在以下环境
系统 xen xen 4.6.0 -
阿里云评分
3.7
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况