中危 RoundCube Webmail 至 1.0.8/1.1.4 SVG File 跨站点脚本漏洞

CVE编号

CVE-2015-8864

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2017-04-14
漏洞描述
RoundCube Webmail是一款基于浏览器的IMAP客户端(邮件客户端)。

RoundCube Webmail中存在跨站脚本漏洞,攻击者可借助特制的Svg图像文件,利用该漏洞注入任意Web脚本或HTML。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://github.com/roundcube/roundcubemail/releases
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 roundcube roundcube_webmail 1.1.1 -
运行在以下环境
应用 roundcube roundcube_webmail 1.1.2 -
运行在以下环境
应用 roundcube roundcube_webmail 1.1.3 -
运行在以下环境
应用 roundcube webmail * Up to
(including)
1.0.8
运行在以下环境
应用 roundcube webmail 1.1 -
运行在以下环境
应用 roundcube webmail 1.1.4 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.1.5+dfsg.1-1
运行在以下环境
系统 debian_7 roundcube * Up to
(excluding)
0.7.2-9+deb7u3
运行在以下环境
系统 fedora_22 roundcube * Up to
(excluding)
1.1.5-1.fc22
运行在以下环境
系统 fedora_23 roundcube * Up to
(excluding)
1.1.5-1.fc23
运行在以下环境
系统 fedora_24 roundcube * Up to
(excluding)
1.1.5-1.fc24
运行在以下环境
系统 fedora_EPEL_6 roundcube * Up to
(excluding)
1.0.9-1.el6
运行在以下环境
系统 fedora_EPEL_7 roundcube * Up to
(excluding)
1.1.5-1.el7
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse opensuse 13.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_13.2 roundcube * Up to
(excluding)
1.0.9-20.1
运行在以下环境
系统 opensuse_Leap_42.1 roundcube * Up to
(excluding)
1.1.5-9.1
运行在以下环境
系统 ubuntu_16.04.7_lts roundcube * Up to
(excluding)
1.2~beta+dfsg.1-0ubuntu1
运行在以下环境
系统 ubuntu_16.04_lts roundcube * Up to
(excluding)
1.2~beta+dfsg.1-0ubuntu1
运行在以下环境
系统 ubuntu_18.04.5_lts roundcube * Up to
(excluding)
1.3.6+dfsg.1-1
运行在以下环境
系统 ubuntu_18.04_lts roundcube * Up to
(excluding)
1.3.6+dfsg.1-1
运行在以下环境
系统 ubuntu_18.10 roundcube * Up to
(excluding)
1.3.6+dfsg.1-1
阿里云评分
4.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况