中危 PHP ‘libxml_disable_entity_loader()’拒绝服务漏洞

CVE编号

CVE-2015-8866

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2016-05-22 14:59:00
漏洞描述
PHP是一种开源的通用计算机脚本语言。
PHP 线程间可以共享‘libxml_disable_entity_loader()’设置,允许远程攻击者可利用该漏洞提交XML外部实体注入和实体扩展使应用程序崩溃。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugs.php.net/bug.php?id=64938
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * From
(including)
5.5.0
Up to
(excluding)
5.5.22
运行在以下环境
应用 php php * From
(including)
5.6.0
Up to
(excluding)
5.6.6
2
运行在以下环境
系统 opensuse_Leap_42.1 php5-devel * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-firebird * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-snmp * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-ctype * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvshm * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-wddx * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-posix * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tidy * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-curl * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gmp * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pcntl * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvsem * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 apache2-mod_php5 * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pdo * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sqlite * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sockets * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-iconv * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvmsg * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-fileinfo * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-opcache * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pgsql * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlreader * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gd * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5 * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-json * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xsl * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pear * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gettext * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-zip * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-dom * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-phar * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-zlib * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mbstring * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-shmop * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mcrypt * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlrpc * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-dba * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-bcmath * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-readline * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mssql * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlwriter * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-enchant * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pspell * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tokenizer * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-ftp * Up to
(excluding)
5.5.14-47.1
3
运行在以下环境
系统 opensuse_13.2 php5-iconv * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-sysvmsg * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-fileinfo * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-opcache * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-pgsql * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-xmlreader * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-gd * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5 * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-json * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-xsl * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-pear * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-gettext * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-zip * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-dom * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-phar * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-zlib * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-mbstring * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-shmop * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-mcrypt * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-xmlrpc * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-dba * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-bcmath * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-readline * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-mssql * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-xmlwriter * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-enchant * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-pspell * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-tokenizer * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-ftp * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-devel * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-firebird * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-snmp * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-ctype * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-sysvshm * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-wddx * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-posix * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-tidy * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-curl * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-gmp * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-pcntl * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-sysvsem * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 apache2-mod_php5 * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-pdo * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-sqlite * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_13.2 php5-sockets * Up to
(excluding)
5.6.1-57.1
4
运行在以下环境
系统 suse_11_SP4 php5-iconv * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-sysvmsg * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-fileinfo * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-opcache * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-pgsql * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-xmlreader * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-gd * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5 * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-json * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-xsl * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-pear * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-gettext * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-zip * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-dom * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-phar * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-zlib * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-mbstring * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-shmop * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-mcrypt * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-xmlrpc * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-dba * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-bcmath * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-readline * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-mssql * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-xmlwriter * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-enchant * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-pspell * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-tokenizer * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-ftp * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-devel * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-firebird * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-snmp * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-ctype * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-sysvshm * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-wddx * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-posix * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-tidy * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-curl * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-gmp * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-pcntl * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-sysvsem * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 apache2-mod_php5 * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-pdo * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-sqlite * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 suse_11_SP4 php5-sockets * Up to
(excluding)
5.3.17-71.1
阿里云评分
4.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况