低危 PHP 至 5.6.11 GD Extension imagefilltoborder 内存破坏漏洞

CVE编号

CVE-2015-8874

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-16
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。GD是其中的一个图形扩展库组件。

PHP 5.6.12之前版本的GD组件中存在拒绝服务漏洞。远程攻击者可借助特制的imagefilltoborder调用利用该漏洞造成拒绝服务。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugs.php.net/bug.php?id=66387
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.6.11
运行在以下环境
系统 alpine_3.2 gd * Up to
(excluding)
2.2.1-r2
运行在以下环境
系统 alpine_3.3 gd * Up to
(excluding)
2.2.1-r2
运行在以下环境
系统 alpine_3.4 gd * Up to
(excluding)
2.2.2-r0
运行在以下环境
系统 amazon linux_AMI gd * Up to
(excluding)
5.6.24-1.126.amzn1
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
5.6.24-1.126.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.12+dfsg-0+deb8u1
运行在以下环境
系统 debian_7 gd * Up to
(excluding)
2.0.36~rc1~dfsg-6.1+deb7u3
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 fedora_23 gd * Up to
(excluding)
2.1.1-8.fc23
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
2.2.2-1.fc24
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
5.6.1-66.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
5.5.14-50.1
运行在以下环境
系统 sles_11_SP4 gd * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 sles_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-59
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 ubuntu_12.04_lts libgd2 * Up to
(excluding)
2.0.36~rc1~dfsg-6ubuntu2.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.1
运行在以下环境
系统 ubuntu_14.04_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.1
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况