低危 libarchive up to 3.1.x archive_string.c archive_string_append 拒绝服务漏洞

CVE编号

CVE-2015-8918

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-21
漏洞描述
libarchive是一个多格式存档和压缩库。

libarchive的CAB解析器中存在未明漏洞。攻击者可利用该漏洞造成内存覆盖。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.libarchive.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libarchive libarchive * Up to
(including)
3.1.901a
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 novell suse_linux_enterprise_desktop 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_server 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_software_development_kit 12.0 -
运行在以下环境
系统 opensuse_Leap_42.1 bsdtar * Up to
(excluding)
3.1.2-13.2
运行在以下环境
系统 opensuse_Leap_42.1 libarchive2 * Up to
(excluding)
3.1.2-13.2
运行在以下环境
系统 sles_11_SP4 bsdtar * Up to
(excluding)
2.5.5-9.1
运行在以下环境
系统 sles_11_SP4 libarchive2 * Up to
(excluding)
2.5.5-9.1
运行在以下环境
系统 sles_12 libarchive13 * Up to
(excluding)
3.1.2-22
运行在以下环境
系统 sles_12_SP1 bsdtar * Up to
(excluding)
3.1.2-22.1
运行在以下环境
系统 sles_12_SP1 libarchive2 * Up to
(excluding)
3.1.2-22.1
运行在以下环境
系统 suse_11_SP4 libarchive2 * Up to
(excluding)
2.5.5-9.1
运行在以下环境
系统 suse_12 libarchive13 * Up to
(excluding)
3.1.2-22
运行在以下环境
系统 suse_12_SP1 libarchive2 * Up to
(excluding)
3.1.2-22.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况