低危 libarchive up to 3.1.x TAR File archive_read_support_format_ar.c _ar_read_header 拒绝服务漏洞

CVE编号

CVE-2015-8920

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-21
漏洞描述
libarchive是一个多格式存档和压缩库。

libarchive的ar解析器中存在安全漏洞,攻击者可利用该漏洞造成栈越边界读取。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.libarchive.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libarchive libarchive * Up to
(including)
3.1.901a
运行在以下环境
系统 amazon linux_AMI libarchive * Up to
(excluding)
3.1.2-10.11.amzn1
运行在以下环境
系统 amazon_AMI libarchive * Up to
(excluding)
3.1.2-10.11.amzn1
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 centos_6 libarchive * Up to
(excluding)
2.8.3-7.el6_8
运行在以下环境
系统 centos_7 libarchive * Up to
(excluding)
3.1.2-10.el7_2
运行在以下环境
系统 debian DPKG * Up to
(excluding)
3.2.0-2
运行在以下环境
系统 debian_7 libarchive * Up to
(excluding)
3.0.4-3+wheezy2
运行在以下环境
系统 debian_8 libarchive * Up to
(excluding)
3.1.2-11+deb8u2
运行在以下环境
系统 novell suse_linux_enterprise_desktop 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_server 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_software_development_kit 12.0 -
运行在以下环境
系统 opensuse_Leap_42.1 libarchive * Up to
(excluding)
3.1.2-13.2
运行在以下环境
系统 oracle linux_6 libarchive * Up to
(excluding)
2.8.3-7.el6_8
运行在以下环境
系统 oracle linux_7 libarchive * Up to
(excluding)
3.1.2-10.el7_2
运行在以下环境
系统 oracle_6 libarchive * Up to
(excluding)
2.8.3-7.el6_8
运行在以下环境
系统 oracle_7 libarchive * Up to
(excluding)
3.1.2-10.el7_2
运行在以下环境
系统 redhat_6 libarchive * Up to
(excluding)
0:2.8.3-7.el6_8
运行在以下环境
系统 redhat_7 bsdcpio * Up to
(excluding)
0:3.1.2-10.el7_2
运行在以下环境
系统 sles_11_SP4 libarchive * Up to
(excluding)
2.5.5-9.1
运行在以下环境
系统 sles_12 libarchive13 * Up to
(excluding)
3.1.2-22
运行在以下环境
系统 sles_12_SP1 libarchive * Up to
(excluding)
3.1.2-22.1
运行在以下环境
系统 suse_11_SP4 libarchive * Up to
(excluding)
2.5.5-9.1
运行在以下环境
系统 suse_12 libarchive13 * Up to
(excluding)
3.1.2-22
运行在以下环境
系统 suse_12_SP1 libarchive * Up to
(excluding)
3.1.2-22.1
运行在以下环境
系统 ubuntu_12.04.5_lts libarchive * Up to
(excluding)
3.0.3-6ubuntu1.3
运行在以下环境
系统 ubuntu_12.04_lts libarchive * Up to
(excluding)
3.0.3-6ubuntu1.3
运行在以下环境
系统 ubuntu_14.04 libarchive * Up to
(excluding)
3.1.2-7ubuntu2.3
运行在以下环境
系统 ubuntu_14.04.6_lts libarchive * Up to
(excluding)
3.1.2-7ubuntu2.3
运行在以下环境
系统 ubuntu_14.04_lts libarchive * Up to
(excluding)
3.1.2-7ubuntu2.3
运行在以下环境
系统 ubuntu_16.04 libarchive * Up to
(excluding)
3.1.2-11ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts libarchive * Up to
(excluding)
3.1.2-11ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04_lts libarchive * Up to
(excluding)
3.1.2-11ubuntu0.16.04.2
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况