低危 GNU libidn up to 1.32 越界读取漏洞

CVE编号

CVE-2015-8948

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-08
漏洞描述
GNU GNU Libidn是一个通过IETF国际域名(IDN)实施字符串预处理、Punycode和IDNA规格定义的包。
GNU Libidn 1.33之前的版本中的idn存在拒绝服务漏洞。远程攻击者可利用该漏洞获取敏感的内存信息,触发越边界读取。
解决建议

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://lists.gnu.org/archive/html/help-libidn/2016-07/msg00009.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu libidn * Up to
(including)
1.32
运行在以下环境
系统 alpine_3.10 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.11 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.12 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.13 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.14 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.15 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.16 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.2 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.3 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.4 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.5 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.6 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.7 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.8 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_3.9 libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 alpine_edge libidn * Up to
(excluding)
1.33-r0
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.33-1
运行在以下环境
系统 debian_7 libidn * Up to
(excluding)
1.25-2+deb7u2
运行在以下环境
系统 debian_8 libidn * Up to
(excluding)
1.29-1+deb8u2
运行在以下环境
系统 fedora_23 libidn * Up to
(excluding)
1.33-1.fc23
运行在以下环境
系统 fedora_24 libidn * Up to
(excluding)
1.33-1.fc24
运行在以下环境
系统 fedora_25 libidn * Up to
(excluding)
1.33-1.fc25
运行在以下环境
系统 fedora_EPEL_7 libidn * Up to
(excluding)
1.33-1.el7
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_13.2 libidn * Up to
(excluding)
1.33-3.6.1
运行在以下环境
系统 opensuse_Leap_42.1 libidn * Up to
(excluding)
1.28-6.1
运行在以下环境
系统 sles_11_SP4 libidn * Up to
(excluding)
1.10-6.1
运行在以下环境
系统 sles_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 sles_12_SP1 libidn * Up to
(excluding)
1.28-4.1
运行在以下环境
系统 suse_11_SP4 libidn * Up to
(excluding)
1.10-6.1
运行在以下环境
系统 suse_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 suse_12_SP1 libidn * Up to
(excluding)
1.28-4.1
运行在以下环境
系统 ubuntu_12.04.5_lts libidn * Up to
(excluding)
1.23-2ubuntu0.1
运行在以下环境
系统 ubuntu_12.04_lts libidn * Up to
(excluding)
1.23-2ubuntu0.1
运行在以下环境
系统 ubuntu_14.04 libidn * Up to
(excluding)
1.28-1ubuntu2.1
运行在以下环境
系统 ubuntu_14.04.6_lts libidn * Up to
(excluding)
1.28-1ubuntu2.1
运行在以下环境
系统 ubuntu_14.04_lts libidn * Up to
(excluding)
1.28-1ubuntu2.1
运行在以下环境
系统 ubuntu_16.04 libidn * Up to
(excluding)
1.32-3ubuntu1.1
运行在以下环境
系统 ubuntu_16.04.7_lts libidn * Up to
(excluding)
1.32-3ubuntu1.1
运行在以下环境
系统 ubuntu_16.04_lts libidn * Up to
(excluding)
1.32-3ubuntu1.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况