低危 GNU Bash本地代码执行漏洞

CVE编号

CVE-2016-0634

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-29 04:29:00
漏洞描述
bash 4.3中提示字符串中的'\ h'扩展允许远程身份验证的用户通过放置在机器的'主机名'中的shell元字符执行任意代码。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新(或目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载):
https://bugzilla.redhat.com/show_bug.cgi?id=1377613
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu bash 4.3 -
运行在以下环境
系统 alpine_3.10 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.11 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.12 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.13 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.14 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.15 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.7 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.8 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_3.9 bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 alpine_edge bash * Up to
(excluding)
4.4.12-r1
运行在以下环境
系统 amazon_AMI bash * Up to
(excluding)
4.2.46-28.37.amzn1
运行在以下环境
系统 debian_8 bash * Up to
(excluding)
4.3-11+deb8u1
运行在以下环境
系统 fedora_23 bash * Up to
(excluding)
4.3.42-4.fc23
运行在以下环境
系统 fedora_24 bash * Up to
(excluding)
4.3.42-6.fc24
运行在以下环境
系统 fedora_25 bash * Up to
(excluding)
4.3.43-3.fc25
运行在以下环境
系统 opensuse_13.2 bash * Up to
(excluding)
4.2-75.5.1
运行在以下环境
系统 opensuse_Leap_42.1 bash * Up to
(excluding)
6.2-81.1
运行在以下环境
系统 opensuse_Leap_42.3 bash * Up to
(excluding)
4.3-83.6.1
运行在以下环境
系统 oracle_6 bash * Up to
(excluding)
4.1.2-48.el6
运行在以下环境
系统 oracle_7 bash * Up to
(excluding)
4.2.46-28.el7
运行在以下环境
系统 suse_11_SP4 bash * Up to
(excluding)
5.2-147.29.1
运行在以下环境
系统 suse_12_SP1 bash * Up to
(excluding)
4.2-82.1
运行在以下环境
系统 suse_12_SP3 bash * Up to
(excluding)
4.3-83.10.1
运行在以下环境
系统 ubuntu_14.04 bash * Up to
(excluding)
4.3-7ubuntu1.7
运行在以下环境
系统 ubuntu_16.04 bash * Up to
(excluding)
4.3-14ubuntu1.2
阿里云评分
2.4
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况