低危 Expat 中的远程代码执行漏洞

CVE编号

CVE-2016-0718

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-27
漏洞描述
Expat,一个用C语言编写的面向流的XML解析器库。
该漏洞允许攻击者发起拒绝服务攻击或者执行任意代码。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新(或目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载):
https://bugzilla.mozilla.org/show_bug.cgi?id=1236923
参考链接
http://lists.apple.com/archives/security-announce/2016/Jul/msg00000.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00064.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00006.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00007.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00010.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00004.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00029.html
http://packetstormsecurity.com/files/141350/ESET-Endpoint-Antivirus-6-Remote-...
http://rhn.redhat.com/errata/RHSA-2016-2824.html
http://seclists.org/fulldisclosure/2017/Feb/68
http://support.eset.com/ca6333/
http://www.debian.org/security/2016/dsa-3582
http://www.mozilla.org/security/announce/2016/mfsa2016-68.html
http://www.openwall.com/lists/oss-security/2016/05/17/12
http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
http://www.securityfocus.com/bid/90729
http://www.securitytracker.com/id/1036348
http://www.securitytracker.com/id/1036415
http://www.securitytracker.com/id/1037705
http://www.ubuntu.com/usn/USN-2983-1
http://www.ubuntu.com/usn/USN-3044-1
https://access.redhat.com/errata/RHSA-2018:2486
https://bugzilla.mozilla.org/show_bug.cgi?id=1236923
https://bugzilla.redhat.com/show_bug.cgi?id=1296102
https://kc.mcafee.com/corporate/index?page=content&id=SB10365
https://security.gentoo.org/glsa/201701-21
https://source.android.com/security/bulletin/2016-11-01.html
https://support.apple.com/HT206903
https://www.tenable.com/security/tns-2016-20
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat expat * Up to
(excluding)
2.2.0
运行在以下环境
应用 mozilla firefox * Up to
(excluding)
48.0
运行在以下环境
应用 suse linux_enterprise_debuginfo 11 -
运行在以下环境
应用 suse studio_onsite 1.3 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
48.0-1
运行在以下环境
系统 redhat_7 expat * Up to
(excluding)
0:2.0.1-13.el6_8
运行在以下环境
系统 suse_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 ubuntu_12.04.5_lts expat * Up to
(excluding)
2.0.1-7.2ubuntu1.3
运行在以下环境
系统 ubuntu_12.04_lts expat * Up to
(excluding)
2.0.1-7.2ubuntu1.3
运行在以下环境
系统 ubuntu_14.04.6_lts expat * Up to
(excluding)
2.1.0-4ubuntu1.2
运行在以下环境
系统 ubuntu_14.04_lts expat * Up to
(excluding)
2.1.0-4ubuntu1.2
运行在以下环境
系统 ubuntu_16.04.7_lts expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04_lts expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts expat * Up to
(excluding)
2.1.1-1ubuntu1
运行在以下环境
系统 ubuntu_18.04_lts expat * Up to
(excluding)
2.1.1-1ubuntu1
运行在以下环境
系统 ubuntu_18.10 expat * Up to
(excluding)
2.1.1-1ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况