低危 Haxx Libcurl存在未明漏洞

CVE编号

CVE-2016-0755

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-01-30
漏洞描述
Haxx Libcurl是瑞典Haxx公司的一个免费、开源的客户端URL传输库。该库支持FTP、FTPS、TFTP、HTTP等。

Haxx Libcurl的lib/url.c文件中的‘ConnectionExists’函数未能正确重用NTLM-authenticated代理连接,允许远程攻击者可通过发送请求伪装成其他用户进行身份验证。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://curl.haxx.se/docs/adv_20160127A.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * Up to
(including)
7.46.0
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.40.0-8.54.amzn1
运行在以下环境
系统 debian_8 curl * Up to
(excluding)
7.38.0-4+deb8u1
运行在以下环境
系统 fedora_22 curl * Up to
(excluding)
7.40.0-8.fc22
运行在以下环境
系统 fedora_23 curl * Up to
(excluding)
7.43.0-5.fc23
运行在以下环境
系统 fedora_EPEL_7 curl * Up to
(excluding)
7.47.0-1.el7
运行在以下环境
系统 opensuse_13.2 curl * Up to
(excluding)
7.42.1-19.1
运行在以下环境
系统 opensuse_Leap_42.1 curl * Up to
(excluding)
7.37.0-7.1
运行在以下环境
系统 suse_11_SP3 curl * Up to
(excluding)
7.19.7-1.46.1
运行在以下环境
系统 suse_11_SP4 curl * Up to
(excluding)
7.19.7-1.46.1
运行在以下环境
系统 suse_12 curl * Up to
(excluding)
7.37.0-18.1
运行在以下环境
系统 suse_12_SP1 curl * Up to
(excluding)
7.37.0-18.1
运行在以下环境
系统 ubuntu_14.04 curl * Up to
(excluding)
7.35.0-1ubuntu2.6
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况