低危 Python 至 2.7.11 CGI Script CGIHandler HTTP_PROXY 重定向漏洞

CVE编号

CVE-2016-1000110

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-11-28
漏洞描述
据发现,Python CGIHandler类没有正确保护CGI上下文中的HTTP_PROXY变量名冲突。远程攻击者可能会利用此漏洞将Python CGI脚本执行的HTTP请求通过恶意HTTP请求重定向到攻击者控制的代理。

解决建议
厂商尚未发布漏洞修复方案,请关注厂商主页及时获取更新信息:
https://www.python.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python * Up to
(excluding)
2.7.12
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 redhat_7 python * Up to
(excluding)
0:2.7.5-38.el7_2
运行在以下环境
系统 suse_12 python-devel * Up to
(excluding)
2.7.9-24
运行在以下环境
系统 ubuntu_12.04.5_lts python2.7 * Up to
(excluding)
2.7.3-0ubuntu3.9
运行在以下环境
系统 ubuntu_12.04_lts python2.7 * Up to
(excluding)
2.7.3-0ubuntu3.9
运行在以下环境
系统 ubuntu_14.04.6_lts python2.7 * Up to
(excluding)
2.7.6-8ubuntu0.3
运行在以下环境
系统 ubuntu_14.04_lts python2.7 * Up to
(excluding)
2.7.6-8ubuntu0.3
运行在以下环境
系统 ubuntu_16.04.7_lts python2.7 * Up to
(excluding)
2.7.12-1ubuntu0~16.04.1
运行在以下环境
系统 ubuntu_16.04_lts python2.7 * Up to
(excluding)
2.7.12-1ubuntu0~16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts python2.7 * Up to
(excluding)
2.7.12-3build1
运行在以下环境
系统 ubuntu_18.04_lts python2.7 * Up to
(excluding)
2.7.12-3build1
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-601 指向未可信站点的URL重定向(开放重定向)
阿里云安全产品覆盖情况