低危 Bouncy Castle JCE Provider存在未明漏洞

CVE编号

CVE-2016-1000340

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-05
漏洞描述
Bouncy Castle JCE Provider是一款基于Java的加密包。

Bouncy Castle JCE Provider 1.51版本至1.55版本中平方的实现存在安全漏洞。目前没有详细的漏洞描述。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/bcgit/bc-java/commit/790642084c4e0cadd47352054f868cc8397e2c00#diff-e5934feac8203ca0104ab291a3560a31
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 bouncycastle legion-of-the-bouncy-castle-java-crytography-api * From
(including)
1.51
Up to
(including)
1.55
运行在以下环境
系统 opensuse_Leap_42.3 bouncycastle * Up to
(excluding)
1.59-23.3.1
运行在以下环境
系统 opensuse_Leap_42.3 bouncycastle-javadoc * Up to
(excluding)
1.59-23.3.1
运行在以下环境
系统 ubuntu_14.04.6_lts bouncycastle * Up to
(excluding)
1.49+dfsg-2
运行在以下环境
系统 ubuntu_18.04.5_lts bouncycastle * Up to
(excluding)
1.59-1
运行在以下环境
系统 ubuntu_18.10 bouncycastle * Up to
(excluding)
1.60-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
阿里云安全产品覆盖情况