低危 ImageMagick 缓冲区错误漏洞

CVE编号

CVE-2016-10070

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-03-04
漏洞描述
在6.9.4-0之前的ImageMagick中的coders / mat.c中的CalcMinMax函数中基于堆的缓冲区溢出允许远程攻击者通过精心制作的mat文件导致拒绝服务(越界读取和应用程序崩溃)。

解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.imagemagick.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * Up to
(including)
6.9.3-10
运行在以下环境
系统 debian DPKG * Up to
(excluding)
8:6.9.6.2+dfsg-2
运行在以下环境
系统 debian_7 imagemagick * Up to
(excluding)
8:6.7.7.10-5+deb7u10
运行在以下环境
系统 debian_8 imagemagick * Up to
(excluding)
8:6.8.9.9-5+deb8u2
运行在以下环境
系统 fedora_25 imagemagick * Up to
(excluding)
7.0.6-9.2.fc25
运行在以下环境
系统 fedora_26 imagemagick * Up to
(excluding)
7.0.6-9.2.fc26
运行在以下环境
系统 opensuse_Leap_42.1 imagemagick * Up to
(excluding)
1.3.21-26.1
运行在以下环境
系统 opensuse_Leap_42.2 imagemagick * Up to
(excluding)
1.3.25-9.1
运行在以下环境
系统 suse_11_SP4 imagemagick * Up to
(excluding)
6.4.3.6-7.65.1
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-70
运行在以下环境
系统 suse_12_SP1 imagemagick * Up to
(excluding)
1-6.8.8.1-59.1
运行在以下环境
系统 suse_12_SP2 imagemagick * Up to
(excluding)
1-6.8.8.1-59.1
运行在以下环境
系统 ubuntu_12.04.5_lts imagemagick * Up to
(excluding)
8:6.6.9.7-5ubuntu3.6
运行在以下环境
系统 ubuntu_14.04.6_lts imagemagick * Up to
(excluding)
8:6.7.7.10-6ubuntu3.3
运行在以下环境
系统 ubuntu_16.04 imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.3
运行在以下环境
系统 ubuntu_16.04.7_lts imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.3
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况