低危 Apple macOS up to 10.12.3 apache_mod_php 拒绝服务漏洞

CVE编号

CVE-2016-10159

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-01-25
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言支持多重语法、支持多数据库及操作系统和支持C、C++进行程序扩展等。

PHP 5.6.30之前的版本和7.0.15之前的7.0.x版本中的ext/phar/phar.c文件的phar_parse_pharfile函数存在整数溢出漏洞。远程攻击者可利用该漏洞造成拒绝服务(内存破坏或应用程序崩溃)。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://github.com/php/php-src/commit/ca46d0acbce55019b970fcd4c1e8a10edfdded93
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.6.29
运行在以下环境
应用 php php 7.0.0 -
运行在以下环境
应用 php php 7.0.1 -
运行在以下环境
应用 php php 7.0.10 -
运行在以下环境
应用 php php 7.0.11 -
运行在以下环境
应用 php php 7.0.12 -
运行在以下环境
应用 php php 7.0.13 -
运行在以下环境
应用 php php 7.0.14 -
运行在以下环境
应用 php php 7.0.2 -
运行在以下环境
应用 php php 7.0.3 -
运行在以下环境
应用 php php 7.0.4 -
运行在以下环境
应用 php php 7.0.5 -
运行在以下环境
应用 php php 7.0.6 -
运行在以下环境
应用 php php 7.0.7 -
运行在以下环境
应用 php php 7.0.8 -
运行在以下环境
应用 php php 7.0.9 -
运行在以下环境
系统 amazon_AMI php56 * Up to
(excluding)
7.0.16-1.21.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.30+dfsg-0+deb8u1
运行在以下环境
系统 debian_7 php5 * Up to
(excluding)
5.4.45-0+deb7u7
运行在以下环境
系统 debian_8 php5 * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 opensuse_Leap_42.2 php7-bz2 * Up to
(excluding)
7.0.7-12.1
运行在以下环境
系统 suse_11_SP4 php53-odbc * Up to
(excluding)
5.3.17-101.1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-96
运行在以下环境
系统 ubuntu_12.04.5_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.26
运行在以下环境
系统 ubuntu_14.04 php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.21
运行在以下环境
系统 ubuntu_14.04.6_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.21
运行在以下环境
系统 ubuntu_16.04 php7.0 * Up to
(excluding)
7.0.15-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts php7.0 * Up to
(excluding)
7.0.15-0ubuntu0.16.04.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况