低危 libGD 'gd_gd2.c'整数溢出漏洞

CVE编号

CVE-2016-10168

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-03-16
漏洞描述
libGD(又名GD Graphics Library或libgd2)是美国软件开发者Thomas Boutell所研发的一个开源的用于动态创建图像的库,它支持创建图表、图形和缩略图等。

libgd存在整数溢出漏洞。攻击者可利用此漏洞在受影响应用程序的上下文中执行任意代码。
解决建议
用户可联系供应商获得补丁信息:
https://github.com/libgd/libgd/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * Up to
(including)
2.2.3
运行在以下环境
系统 alpine_3.3 gd * Up to
(excluding)
2.2.4-r0
运行在以下环境
系统 alpine_3.4 gd * Up to
(excluding)
2.2.4-r0
运行在以下环境
系统 alpine_3.5 gd * Up to
(excluding)
2.2.4-r0
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
5.6.30-1.133.amzn1
运行在以下环境
系统 centos_7 gd * Up to
(excluding)
5.4.16-43.el7_4
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.30+dfsg-0+deb8u1
运行在以下环境
系统 debian_7 gd * Up to
(excluding)
2.0.36~rc1~dfsg-6.1+deb7u8
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
0.2.8.4-50.fc24
运行在以下环境
系统 fedora_25 gd * Up to
(excluding)
0.2.8.4-50.fc25
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-16.1
运行在以下环境
系统 opensuse_Leap_42.2 gd * Up to
(excluding)
2.1.0-16.1
运行在以下环境
系统 oracle_7 gd * Up to
(excluding)
5.4.16-43.el7_4
运行在以下环境
系统 redhat_7 php * Up to
(excluding)
0:5.4.16-43.el7_4
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
2.0.36.RC1-52.32.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-23
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-23.1
运行在以下环境
系统 suse_12_SP2 gd * Up to
(excluding)
2.1.0-23.1
运行在以下环境
系统 ubuntu_12.04.5_lts libgd2 * Up to
(excluding)
2.0.36~rc1~dfsg-6ubuntu2.4
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.6
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.6
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.6
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.6
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况