低危 Nginx权限提升漏洞

CVE编号

CVE-2016-1247

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-11-30
漏洞描述
Nginx是一款HTTP和反向代理服务器,也可以作为邮件代理服务器。

多款操作系统上的nginx存在本地提权漏洞。由于程序对日志文件分配弱权限,本地及远程攻击者可利用该漏洞获取root权限。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://nginx.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * Up to
(including)
1.10.0
运行在以下环境
应用 nginx nginx * Up to
(including)
1.10.1
运行在以下环境
应用 nginx nginx * Up to
(including)
1.4.3
运行在以下环境
应用 nginx nginx * Up to
(including)
1.6.2
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.10.2-1
运行在以下环境
系统 debian_8 nginx * Up to
(excluding)
1.6.2-5+deb8u3
运行在以下环境
系统 fedora_32 nginx * Up to
(excluding)
1.20.0-2.fc32
运行在以下环境
系统 fedora_33 nginx * Up to
(excluding)
1.20.0-2.fc33
运行在以下环境
系统 fedora_34 nginx * Up to
(excluding)
1.20.0-2.fc34
运行在以下环境
系统 fedora_EPEL_7 nginx * Up to
(excluding)
1.20.1-2.el7
运行在以下环境
系统 ubuntu_12.04.5_lts nginx * Up to
(excluding)
1.1.19-1ubuntu0.8
运行在以下环境
系统 ubuntu_14.04 nginx * Up to
(excluding)
1.4.6-1ubuntu3.6
运行在以下环境
系统 ubuntu_14.04.6_lts nginx * Up to
(excluding)
1.4.6-1ubuntu3.6
运行在以下环境
系统 ubuntu_16.04 nginx * Up to
(excluding)
1.10.0-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_16.04.7_lts nginx * Up to
(excluding)
1.10.0-0ubuntu0.16.04.3
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-59 在文件访问前对链接解析不恰当(链接跟随)
阿里云安全产品覆盖情况