低危 Vim输入验证漏洞

CVE编号

CVE-2016-1248

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-11-24
漏洞描述
Vim是一款开源的、可配置的用于创建和更改任何类型文本的文本编辑器,它可使用在大多数UNIX系统和Apple OS X中。

Vim patch 8.0.0056之前的版本中存在安全漏洞,该漏洞源于程序未能正确验证‘filetype’、‘syntax’和‘keymap’选项的值。攻击者可利用该漏洞执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://github.com/vim/vim/releases/tag/v8.0.0056
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(including)
8.0.0055
运行在以下环境
系统 alpine_3.10 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.11 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.12 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.13 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.14 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.15 vim * Up to
(excluding)
8.0.0056-r0
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
8.0.0056-r0
运行在以下环境
系统 alpine_3.2 vim * Up to
(excluding)
7.4.712-r1
运行在以下环境
系统 alpine_3.3 vim * Up to
(excluding)
7.4.943-r4
运行在以下环境
系统 alpine_3.4 vim * Up to
(excluding)
7.4.1831-r2
运行在以下环境
系统 alpine_3.5 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.6 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.7 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.8 vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 alpine_3.9 vim * Up to
(excluding)
8.0.0056-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
0.1.6-r1
运行在以下环境
系统 amazon_AMI vim * Up to
(excluding)
8.0.0134-1.43.amzn1
运行在以下环境
系统 centos_7 vim * Up to
(excluding)
7.4.160-1.el7_3.1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2:8.0.0095-1
运行在以下环境
系统 debian_7 vim * Up to
(excluding)
2:7.3.547-7+deb7u1
运行在以下环境
系统 debian_8 vim * Up to
(excluding)
2:7.4.488-7+deb8u1
运行在以下环境
系统 opensuse_13.2 vim * Up to
(excluding)
7.4.461.hg.6253-3.1
运行在以下环境
系统 opensuse_Leap_42.1 vim * Up to
(excluding)
7.4.326-8.1
运行在以下环境
系统 opensuse_Leap_42.2 vim * Up to
(excluding)
7.4.326-8.2
运行在以下环境
系统 oracle_6 vim * Up to
(excluding)
7.4.160-1.el7_3.1
运行在以下环境
系统 oracle_7 vim * Up to
(excluding)
7.4.629-5.el6_8.1
运行在以下环境
系统 redhat_7 vim-X11 * Up to
(excluding)
2:7.4.629-5.el6_8.1
运行在以下环境
系统 suse_11_SP4 vim * Up to
(excluding)
7.2-8.17.1
运行在以下环境
系统 suse_12 gvim * Up to
(excluding)
7.4.326-16
运行在以下环境
系统 suse_12_SP1 vim * Up to
(excluding)
7.4.326-7.1
运行在以下环境
系统 suse_12_SP2 vim * Up to
(excluding)
7.4.326-7.1
运行在以下环境
系统 ubuntu_12.04.5_lts vim * Up to
(excluding)
2:7.3.429-2ubuntu2.2
运行在以下环境
系统 ubuntu_12.04_lts vim * Up to
(excluding)
2:7.3.429-2ubuntu2.2
运行在以下环境
系统 ubuntu_14.04 vim * Up to
(excluding)
2:7.4.052-1ubuntu3.1
运行在以下环境
系统 ubuntu_14.04.6_lts vim * Up to
(excluding)
2:7.4.052-1ubuntu3.1
运行在以下环境
系统 ubuntu_14.04_lts vim * Up to
(excluding)
2:7.4.052-1ubuntu3.1
运行在以下环境
系统 ubuntu_16.04 vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.2
运行在以下环境
系统 ubuntu_16.04.7_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.2
运行在以下环境
系统 ubuntu_16.04_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.2
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况