Apache HTTP Server 2.4.17/2.4.18 mod_http2 拒绝服务漏洞

CVE编号

CVE-2016-1546

利用情况

暂无

补丁情况

N/A

披露时间

2016-07-07
漏洞描述
Apache HTTP Server是Apache软件基金会的一个开放源代码的网页服务器。

Apache HTTP Server 2.4.17及2.4.18版本,启用mod_http2后,未限制单个HTTP/2连接的同步流工作数量,通过修改流控制窗口,远程攻击者可长时间阻止服务器线程,使工作线程互斥等待,造成拒绝服务。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.apache.org/dist/httpd/CHANGES_2.4
http://svn.apache.org/viewvc?view=revision&revision=1733727
http://httpd.apache.org/security/vulnerabilities_24.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.4.17 -
运行在以下环境
应用 apache http_server 2.4.18 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.4.20-1
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.23-14
CVSS3评分
5.9
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况