低危 Linux Kernel ecryptfs_privileged_open函数导致拒绝服务漏洞

CVE编号

CVE-2016-1583

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-06-27
漏洞描述
Linux kernel是美国Linux基金会发布的操作系统Linux所使用的内核。

Linux kernel的eCryptfs中存在本地提权漏洞。允许攻击者利用该漏洞造成栈溢出。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.kernel.org/
参考链接
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2f3...
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f53...
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00027.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00044.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00056.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00003.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00008.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00009.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00014.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00016.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00018.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00019.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00020.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00021.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00022.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00026.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00055.html
http://packetstormsecurity.com/files/137560/Linux-ecryptfs-Stack-Overflow.html
http://rhn.redhat.com/errata/RHSA-2016-2124.html
http://rhn.redhat.com/errata/RHSA-2016-2766.html
http://www.debian.org/security/2016/dsa-3607
http://www.openwall.com/lists/oss-security/2016/06/10/8
http://www.openwall.com/lists/oss-security/2016/06/22/1
http://www.securityfocus.com/bid/91157
http://www.securitytracker.com/id/1036763
http://www.ubuntu.com/usn/USN-2996-1
http://www.ubuntu.com/usn/USN-2997-1
http://www.ubuntu.com/usn/USN-2998-1
http://www.ubuntu.com/usn/USN-2999-1
http://www.ubuntu.com/usn/USN-3000-1
http://www.ubuntu.com/usn/USN-3001-1
http://www.ubuntu.com/usn/USN-3002-1
http://www.ubuntu.com/usn/USN-3003-1
http://www.ubuntu.com/usn/USN-3004-1
http://www.ubuntu.com/usn/USN-3005-1
http://www.ubuntu.com/usn/USN-3006-1
http://www.ubuntu.com/usn/USN-3007-1
http://www.ubuntu.com/usn/USN-3008-1
https://access.redhat.com/errata/RHSA-2017:2760
https://bugs.chromium.org/p/project-zero/issues/detail?id=836
https://bugzilla.redhat.com/show_bug.cgi?id=1344721
https://github.com/torvalds/linux/commit/2f36db71009304b3f0b95afacd8eba1f9f046b87
https://github.com/torvalds/linux/commit/f0fe970df3838c202ef6c07a4c2b36838ef0a88b
https://github.com/torvalds/linux/commit/f5364c150aa645b3d7daa21b5c0b9feaa1c9cd6d
https://www.exploit-db.com/exploits/39992/
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.6.3
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 novell suse_linux_enterprise_software_development_kit 11.0 -
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.6.2-1
运行在以下环境
系统 linux linux_kernel * Up to
(including)
4.6.2
运行在以下环境
系统 novell suse_linux_enterprise_debuginfo 11.0 -
运行在以下环境
系统 novell suse_linux_enterprise_desktop 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_live_patching 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_module_for_public_cloud 12 -
运行在以下环境
系统 novell suse_linux_enterprise_server 11.0 -
运行在以下环境
系统 novell suse_linux_enterprise_server 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_software_development_kit 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_workstation_extension 12.0 -
运行在以下环境
系统 redhat_5 kernel * Up to
(excluding)
0:2.6.18-416.el5
运行在以下环境
系统 redhat_6 kernel * Up to
(excluding)
0:2.6.32-642.11.1.el6
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.4.21-69
运行在以下环境
系统 suse_12 kernel-default-extra * Up to
(excluding)
4.4.21-69
运行在以下环境
系统 ubuntu_12.04.5_lts linux * Up to
(excluding)
3.2.0-104.145
运行在以下环境
系统 ubuntu_12.04_lts linux * Up to
(excluding)
3.2.0-104.145
运行在以下环境
系统 ubuntu_14.04.6_lts linux * Up to
(excluding)
3.13.0-88.135
运行在以下环境
系统 ubuntu_14.04_lts linux * Up to
(excluding)
3.13.0-88.135
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.4.0-24.43
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-24.43
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况