低危 Apple macOS up to 10.13.1 apache 拒绝服务漏洞

CVE编号

CVE-2016-2161

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-07-28 10:29:00
漏洞描述
在Apache HTTP Server版本2.4.0到2.4.23中,对mod_auth_digest的恶意输入可能导致服务器崩溃,并且即使对于后续有效的请求,每个实例也会继续崩溃。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://rhn.redhat.com/errata/RHSA-2017-1415.html
http://www.debian.org/security/2017/dsa-3796
http://www.securityfocus.com/bid/95076
http://www.securitytracker.com/id/1037508
https://access.redhat.com/errata/RHSA-2017:0906
https://access.redhat.com/errata/RHSA-2017:1161
https://access.redhat.com/errata/RHSA-2017:1413
https://access.redhat.com/errata/RHSA-2017:1414
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr...
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2016-2161
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r04e89e873d54116a0635ef2f7061c15acc5ed27...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rb14daf9cc4e28d18cdc15d6a6ca74e565672fab...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rcc44594d4d6579b90deccd4536b5d31f099ef56...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/re1e3a24664d35bcd0a0e793e0b5fc6ca6c107f9...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://security.gentoo.org/glsa/201701-36
https://security.netapp.com/advisory/ntap-20180423-0001/
https://support.apple.com/HT208221
https://www.tenable.com/security/tns-2017-04
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.4.0 -
运行在以下环境
应用 apache http_server 2.4.1 -
运行在以下环境
应用 apache http_server 2.4.2 -
运行在以下环境
应用 apache http_server 2.4.3 -
运行在以下环境
应用 apache http_server 2.4.6 -
运行在以下环境
应用 apache http_server 2.4.7 -
运行在以下环境
应用 apache http_server 2.4.8 -
运行在以下环境
应用 apache http_server 2.4.9 -
运行在以下环境
应用 apache http_server 2.4.10 -
运行在以下环境
应用 apache http_server 2.4.12 -
运行在以下环境
应用 apache http_server 2.4.14 -
运行在以下环境
应用 apache http_server 2.4.16 -
运行在以下环境
应用 apache http_server 2.4.19 -
运行在以下环境
应用 apache http_server 2.4.20 -
运行在以下环境
应用 apache http_server 2.4.21 -
运行在以下环境
应用 apache http_server 2.4.22 -
运行在以下环境
应用 apache http_server 2.4.23 -
2
运行在以下环境
系统 debian_8 apache2 * Up to
(excluding)
2.4.10-10+deb8u8
3
运行在以下环境
系统 amazon_AMI apache2 * Up to
(excluding)
2.4.25-1.68.amzn1
4
运行在以下环境
系统 centos_7 apache2 * Up to
(excluding)
2.4.6-45.el7.centos.4
5
运行在以下环境
系统 suse_12_SP2 apache2 * Up to
(excluding)
2.4.23-21.1
6
运行在以下环境
系统 suse_12_SP1 apache2 * Up to
(excluding)
2.4.16-19.1
7
运行在以下环境
系统 oracle_7 apache2 * Up to
(excluding)
2.4.6-45.0.1.el7_3.4
8
运行在以下环境
系统 suse_11_SP4 apache2 * Up to
(excluding)
2.2.12-69.1
9
运行在以下环境
系统 opensuse_Leap_42.2 apache2 * Up to
(excluding)
2.4.23-8.3.1
10
运行在以下环境
系统 opensuse_Leap_42.1 apache2 * Up to
(excluding)
2.4.16-18.1
11
运行在以下环境
系统 fedora_25 apache2 * Up to
(excluding)
2.4.25-1.fc25
12
运行在以下环境
系统 fedora_24 apache2 * Up to
(excluding)
2.4.25-1.fc24
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况