中危 Oracle MySQL Workbench 至 6.3.7 OpenSSL 内存破坏漏洞

CVE编号

CVE-2016-2176

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-05 14:59:00
漏洞描述
OpenSSL是一个实现安全套接层和安全传输层协议的通用开源加密库,可支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。
OpenSSL EBCDIC存在越界读漏洞。当程序使用EBCDIC系统X509_NAME_oneline()函数,ASN1字符串超过1024字节可导致越界读,进而可导致在缓冲区返回任意堆栈的数据。
解决建议
厂商已发布升级程序修复该漏洞,请及时更新下载:
https://www.openssl.org/news/vulnerabilities.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * Up to
(including)
1.0.1s
运行在以下环境
应用 openssl openssl 1.0.2 -
运行在以下环境
应用 openssl openssl 1.0.2 beta1 -
运行在以下环境
应用 openssl openssl 1.0.2 beta2 -
运行在以下环境
应用 openssl openssl 1.0.2 beta3 -
运行在以下环境
应用 openssl openssl 1.0.2a -
运行在以下环境
应用 openssl openssl 1.0.2b -
运行在以下环境
应用 openssl openssl 1.0.2c -
运行在以下环境
应用 openssl openssl 1.0.2d -
运行在以下环境
应用 openssl openssl 1.0.2e -
运行在以下环境
应用 openssl openssl 1.0.2f -
运行在以下环境
应用 openssl openssl 1.0.2g -
2
运行在以下环境
系统 alpine_3.7 openssl * Up to
(excluding)
1.0.2h-r0
3
运行在以下环境
系统 alpine_3.4 openssl * Up to
(excluding)
1.0.2h-r0
4
运行在以下环境
系统 alpine_3.5 openssl * Up to
(excluding)
1.0.2h-r0
5
运行在以下环境
系统 alpine_3.6 openssl * Up to
(excluding)
1.0.2h-r0
6
运行在以下环境
系统 alpine_3.3 openssl * Up to
(excluding)
1.0.2h-r0
7
运行在以下环境
系统 alpine_3.8 openssl * Up to
(excluding)
1.0.2h-r0
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况