低危 BeanShell任意命令执行漏洞

CVE编号

CVE-2016-2510

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-04-08
漏洞描述
BeanShell是一个开源的、免费的Java源代码解释器。

BeanShell中存在安全漏洞。攻击者可利用该漏洞执行任意命令。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
http://www.debian.org/security/2016/dsa-3504
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 beanshell beanshell 1.0 -
运行在以下环境
应用 beanshell beanshell 2.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.0b4-16
运行在以下环境
系统 debian_6 bsh * Up to
(excluding)
2.0b4-12+deb6u1
运行在以下环境
系统 debian_7 bsh * Up to
(excluding)
2.0b4-12+deb7u1
运行在以下环境
系统 debian_8 bsh * Up to
(excluding)
2.0b4-15+deb8u1
运行在以下环境
系统 opensuse_13.2 bsh * Up to
(excluding)
2.0.0.b6-27.3.1
运行在以下环境
系统 opensuse_Leap_42.1 bsh * Up to
(excluding)
2.0.0.b5-30.1
运行在以下环境
系统 ubuntu_12.04.5_lts bsh * Up to
(excluding)
2.0b4-12ubuntu0.1
运行在以下环境
系统 ubuntu_14.04 bsh * Up to
(excluding)
2.0b4-15ubuntu0.14.04.1
运行在以下环境
系统 ubuntu_14.04.6_lts bsh * Up to
(excluding)
2.0b4-15ubuntu0.14.04.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
阿里云安全产品覆盖情况