低危 ISC BIND 9存在buffer.c 断言错误拒绝服务漏洞

CVE编号

CVE-2016-2776

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-28
漏洞描述
ISC BIND 9是美国Internet Systems Consortium(ISC)组织所维护的一套DNS域名解析服务软件。

ISC BIND 9存在buffer.c断言错误拒绝服务漏洞。远程攻击者利用漏洞可导致程序断言失败退出缓冲区,最终导致BIND主进程崩溃。
解决建议
厂商已提供漏洞修补方案,请关注厂商主页及时更新:
http://www.isc.org/downloads
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind * Up to
(including)
9.9.9
运行在以下环境
应用 isc bind 9.10.0 -
运行在以下环境
应用 isc bind 9.10.1 -
运行在以下环境
应用 isc bind 9.10.2 -
运行在以下环境
应用 isc bind 9.10.3 -
运行在以下环境
应用 isc bind 9.10.4 -
运行在以下环境
应用 isc bind 9.11.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:9.10.3.dfsg.P4-11
运行在以下环境
系统 hp hp-ux 11.31 -
运行在以下环境
系统 oracle linux 5.0 -
运行在以下环境
系统 oracle linux 6 -
运行在以下环境
系统 oracle linux 7 -
运行在以下环境
系统 oracle solaris 10.0 -
运行在以下环境
系统 oracle solaris 11.3 -
运行在以下环境
系统 oracle vm_server 3.2 -
运行在以下环境
系统 oracle vm_server 3.3 -
运行在以下环境
系统 oracle vm_server 3.4 -
运行在以下环境
系统 redhat_5 bind97 * Up to
(excluding)
32:9.7.0-21.P2.el5_11.7
运行在以下环境
系统 redhat_7 bind * Up to
(excluding)
30:9.3.6-25.P1.el5_11.9
运行在以下环境
系统 sles_12 bind * Up to
(excluding)
9.9.9P1-46
运行在以下环境
系统 ubuntu_12.04_lts bind9 * Up to
(excluding)
1:9.8.1.dfsg.P1-4ubuntu0.17
运行在以下环境
系统 ubuntu_14.04_lts bind9 * Up to
(excluding)
1:9.9.5.dfsg-3ubuntu0.9
运行在以下环境
系统 ubuntu_16.04_lts bind9 * Up to
(excluding)
1:9.10.3.dfsg.P4-8ubuntu1.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况