Puppet pxp-agent 输入验证漏洞

CVE编号

CVE-2016-2786

利用情况

暂无

补丁情况

N/A

披露时间

2016-06-11
漏洞描述
Puppet Server和Agent都是美国Puppet实验室的基于客户端/服务器(C/S)架构的配置管理工具,该工具可用于管理配置文件、用户、cron任务、软件包、系统服务等。

Puppet Server 2.3.2之前版本和Agent 1.4.2之前版本的Puppet Communications Protocol中存在任意代码执行漏洞,该漏洞源于程序未能正确验证证书。远程攻击者可利用该漏洞在代理节点中执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
https://www.puppet.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise 2015.3.2 -
运行在以下环境
应用 puppetlabs puppet_agent 1.3.0 -
运行在以下环境
应用 puppetlabs puppet_agent 1.3.1 -
运行在以下环境
应用 puppetlabs puppet_agent 1.3.2 -
运行在以下环境
应用 puppetlabs puppet_agent 1.3.4 -
运行在以下环境
应用 puppetlabs puppet_agent 1.3.5 -
运行在以下环境
应用 puppetlabs puppet_enterprise 2015.3 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
CVSS3评分
9.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况