Puppet Enterprise prior 2015.3.3 Puppet Communications Protocol 访问控制漏洞

CVE编号

CVE-2016-2787

利用情况

暂无

补丁情况

N/A

披露时间

2017-02-14
漏洞描述
Puppet是一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。

Puppet Enterprise中的Puppet Communications Protocol未能正确的验证代理节点的证书。远程攻击者可利用该漏洞使Puppet Communications Protocol停止运行,造成拒绝服务攻击。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://puppet.com/security/cve/CVE-2016-2787
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise 2015.3.2 -
运行在以下环境
应用 puppetlabs puppet_enterprise 2015.3 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
CVSS3评分
5.3
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-284 访问控制不恰当
阿里云安全产品覆盖情况