Puppet Mcollective远程命令执行漏洞

CVE编号

CVE-2016-2788

利用情况

暂无

补丁情况

N/A

披露时间

2017-02-14
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。

Puppet Mcollective存在远程命令执行漏洞。允许攻击者在应用程序的上下文内执行任意代码。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
https://puppet.com/security/cve/cve-2016-2788
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet marionette_collective 2.7.0 -
运行在以下环境
应用 puppet marionette_collective 2.8.0 -
运行在以下环境
应用 puppet marionette_collective 2.8.1 -
运行在以下环境
应用 puppet marionette_collective 2.8.2 -
运行在以下环境
应用 puppet marionette_collective 2.8.3 -
运行在以下环境
应用 puppet marionette_collective 2.8.4 -
运行在以下环境
应用 puppet marionette_collective 2.8.5 -
运行在以下环境
应用 puppet marionette_collective 2.8.6 -
运行在以下环境
应用 puppet marionette_collective 2.8.7 -
运行在以下环境
应用 puppet marionette_collective 2.8.8 -
运行在以下环境
应用 puppet puppet * From
(including)
2016.2.0
Up to
(excluding)
2016.2.1
运行在以下环境
应用 puppet puppet * From
(including)
3.8.0
Up to
(excluding)
3.8.6
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 ubuntu_18.10 mcollective * Up to
(excluding)
2.12.0+dfsg-1
CVSS3评分
9.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-284 访问控制不恰当
阿里云安全产品覆盖情况