低危 Ansible lxc_container模块权限获取漏洞

CVE编号

CVE-2016-3096

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-06-04 03:59:00
漏洞描述
Ansible是美国Ansible公司的一款计算机系统配置管理器,它可用于发布、管理和编排计算机系统。
Ansible 1.9.6-1之前的版本和2.0.2.0之前的2.x版本中的lxc_container模块中的‘create_script’函数存在安全漏洞。本地攻击者可通过向临时目录下的多个文件实施符号链接攻击利用该漏洞写入任意文件或获取权限。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://github.com/ansible/ansible/blob/v2.0.2.0-1/CHANGELOG.md#202-over-the-hills-and-far-away
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * Up to
(including)
1.9.6
运行在以下环境
应用 redhat ansible 2.0 -
运行在以下环境
应用 redhat ansible 2.0.1 -
2
运行在以下环境
系统 ubuntu_16.04 ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.3
3
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.0.2.0-1.el7
4
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.0.2.0-1.el6
5
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
1.9.6-2.el7
6
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
1.9.6-2.el6
7
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
1.9.6-1.el6
8
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
1.9.6-1.el7
9
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.0.1.0-2
运行在以下环境
系统 ubuntu_18.04_lts ansible * Up to
(excluding)
2.0.2.0-1
运行在以下环境
系统 ubuntu_18.10 ansible * Up to
(excluding)
2.0.2.0-1
运行在以下环境
系统 ubuntu_16.04_lts ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.3
10
运行在以下环境
系统 fedora_23 ansible * Up to
(excluding)
2.0.2.0-1.fc23
11
运行在以下环境
系统 fedora_22 ansible * Up to
(excluding)
2.0.2.0-1.fc22
12
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.0.2.0-1.el7
13
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.0.2.0-1.el6
14
运行在以下环境
系统 fedora_24 ansible * Up to
(excluding)
2.0.2.0-1.fc24
15
运行在以下环境
系统 fedoraproject fedora 22 -
运行在以下环境
系统 fedoraproject fedora 23 -
运行在以下环境
系统 fedoraproject fedora 24 -
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-59 在文件访问前对链接解析不恰当(链接跟随)
阿里云安全产品覆盖情况