低危 Mercurial任意代码执行漏洞

CVE编号

CVE-2016-3105

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-10
漏洞描述
Mercurial是一套使用Python语言编写的跨平台的分布式版本控制软件。

Mercurial使用Git repos中的convert扩展时存在安全漏洞,允许远程攻击者可利用该漏洞提交特殊请求执行任意代码。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://www.slackware.com/changelog/stable.php?cpu=i386
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mercurial mercurial * Up to
(including)
3.7.3
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
3.8.1-1
运行在以下环境
系统 debian_7 mercurial * Up to
(excluding)
2.2.2-4+deb7u3
运行在以下环境
系统 debian_8 mercurial * Up to
(excluding)
3.1.2-2+deb8u2
运行在以下环境
系统 opensuse_Leap_42.1 mercurial * Up to
(excluding)
3.5.1-6.1
运行在以下环境
系统 ubuntu_14.04 mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_14.04.6_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_14.04_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.4
运行在以下环境
系统 ubuntu_16.04 mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_16.04.7_lts mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_16.04_lts mercurial * Up to
(excluding)
3.7.3-1ubuntu1.1
运行在以下环境
系统 ubuntu_18.04.5_lts mercurial * Up to
(excluding)
3.9.1-1
运行在以下环境
系统 ubuntu_18.04_lts mercurial * Up to
(excluding)
3.9.1-1
运行在以下环境
系统 ubuntu_18.10 mercurial * Up to
(excluding)
3.9.1-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-284 访问控制不恰当
阿里云安全产品覆盖情况