中危 PHP WDDX扩展wddx.c缓冲区溢出漏洞

CVE编号

CVE-2016-3141

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2016-04-01
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
PHP是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。PHAR是其中的一个归档扩展模。

PHP的的WDDX扩展中的wddx.c文件存在缓冲区溢出漏洞。远程攻击者可发送包含特制var元素的XML数据上的wddx_deserialize调用,进行拒绝服务攻击。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://git.php.net/?p=php-src.git;a=commit;h=b1bd4119bcafab6f9a8f84d92cd65eec3afeface
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.5.32
运行在以下环境
应用 php php 5.6.0 -
运行在以下环境
应用 php php 5.6.1 -
运行在以下环境
应用 php php 5.6.10 -
运行在以下环境
应用 php php 5.6.11 -
运行在以下环境
应用 php php 5.6.12 -
运行在以下环境
应用 php php 5.6.13 -
运行在以下环境
应用 php php 5.6.14 -
运行在以下环境
应用 php php 5.6.15 -
运行在以下环境
应用 php php 5.6.16 -
运行在以下环境
应用 php php 5.6.17 -
运行在以下环境
应用 php php 5.6.18 -
运行在以下环境
应用 php php 5.6.2 -
运行在以下环境
应用 php php 5.6.3 -
运行在以下环境
应用 php php 5.6.4 -
运行在以下环境
应用 php php 5.6.5 -
运行在以下环境
应用 php php 5.6.6 -
运行在以下环境
应用 php php 5.6.7 -
运行在以下环境
应用 php php 5.6.8 -
运行在以下环境
应用 php php 5.6.9 -
运行在以下环境
系统 apple mac_os_x * Up to
(including)
10.11.4
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.19+dfsg-0+deb8u1
运行在以下环境
系统 opensuse_13.2 apache2-mod_php5 * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5 * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-bcmath * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-ctype * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-curl * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-dba * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-devel * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-dom * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-enchant * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-fileinfo * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-firebird * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-ftp * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-gd * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-gettext * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-gmp * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-iconv * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-json * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-mbstring * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-mcrypt * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-mssql * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-opcache * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-pcntl * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-pdo * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-pear * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-pgsql * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-phar * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-posix * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-pspell * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-readline * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-shmop * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-snmp * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-sockets * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-sqlite * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-sysvmsg * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-sysvsem * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-sysvshm * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-tidy * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-tokenizer * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-wddx * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-xmlreader * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-xmlrpc * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-xmlwriter * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-xsl * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-zip * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_13.2 php5-zlib * Up to
(excluding)
5.6.1-53.3
运行在以下环境
系统 opensuse_Leap_42.1 apache2-mod_php5 * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5 * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-bcmath * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-ctype * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-curl * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-dba * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-devel * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-dom * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-enchant * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-fileinfo * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-firebird * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-ftp * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gd * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gettext * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gmp * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-iconv * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-json * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mbstring * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mcrypt * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mssql * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-opcache * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pcntl * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pdo * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pear * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pgsql * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-phar * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-posix * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pspell * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-readline * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-shmop * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-snmp * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sockets * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sqlite * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvmsg * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvsem * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvshm * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tidy * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tokenizer * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-wddx * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlreader * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlrpc * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlwriter * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xsl * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-zip * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-zlib * Up to
(excluding)
5.5.14-44.1
运行在以下环境
系统 sles_11_SP4 apache2-mod_php5 * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5 * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-bcmath * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-ctype * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-curl * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-dba * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-devel * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-dom * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-enchant * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-fileinfo * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-firebird * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-ftp * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-gd * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-gettext * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-gmp * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-iconv * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-json * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-mbstring * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-mcrypt * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-mssql * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-opcache * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-pcntl * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-pdo * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-pear * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-pgsql * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-phar * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-posix * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-pspell * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-readline * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-shmop * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-snmp * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-sockets * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-sqlite * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-sysvmsg * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-sysvsem * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-sysvshm * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-tidy * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-tokenizer * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-wddx * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-xmlreader * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-xmlrpc * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-xmlwriter * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-xsl * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-zip * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_11_SP4 php5-zlib * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 sles_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-53
运行在以下环境
系统 suse_11_SP4 php5 * Up to
(excluding)
5.3.17-59.1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-53
运行在以下环境
系统 ubuntu_12.04.5_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.22
运行在以下环境
系统 ubuntu_12.04_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.22
运行在以下环境
系统 ubuntu_14.04 php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.16
运行在以下环境
系统 ubuntu_14.04.6_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.16
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.16
阿里云评分
6.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况