低危 bzip2 1.0.6 bzip2recover 内存错误引用漏洞

CVE编号

CVE-2016-3189

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-07-01 06:59:00
漏洞描述
bzip2 1.0.6中的bzip2recover中的UAF漏洞使远程攻击者可以通过精心制作的bzip2文件来导致拒绝服务(崩溃),该文件与设置在block开始之前的block结束有关。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.bzip.org/
参考链接
http://packetstormsecurity.com/files/153644/Slackware-Security-Advisory-bzip2...
http://packetstormsecurity.com/files/153957/FreeBSD-Security-Advisory-FreeBSD...
http://www.openwall.com/lists/oss-security/2016/06/20/1
http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
http://www.securityfocus.com/bid/91297
http://www.securitytracker.com/id/1036132
https://bugzilla.redhat.com/show_bug.cgi?id=1319648
https://lists.apache.org/thread.html/r19b4a70ac52093115fd71d773a7a4f579599e62...
https://lists.apache.org/thread.html/r1dc4c9b3bd559301bdb1557245f78b8910146ef...
https://lists.apache.org/thread.html/r481cda41fefb03e04c51484ed14421d812e5ce9...
https://lists.apache.org/thread.html/r4ad2ea01354e394b7fa8c78a184b7e1634d51be...
https://lists.apache.org/thread.html/r5f7ac2bd631ccb12ced65b71ff11f94e76d05b2...
https://lists.apache.org/thread.html/r5f80cf3ade5bb73410643e885fe6b7bf9f0222d...
https://lists.apache.org/thread.html/r6e3962fc9f6a79851f70cffdec5759065969cec...
https://lists.apache.org/thread.html/ra0adb9653c7de9539b93cc8434143b655f753b9...
https://lists.apache.org/thread.html/redf17d8ad16140733b25ca402ae825d6dfa9b85...
https://lists.apache.org/thread.html/rffebcbeaace56ff1fed7916700d2f414ca13663...
https://lists.debian.org/debian-lts-announce/2019/06/msg00021.html
https://seclists.org/bugtraq/2019/Aug/4
https://seclists.org/bugtraq/2019/Jul/22
https://security.FreeBSD.org/advisories/FreeBSD-SA-19:18.bzip2.asc
https://security.gentoo.org/glsa/201708-08
https://usn.ubuntu.com/4038-1/
https://usn.ubuntu.com/4038-2/
https://www.oracle.com/security-alerts/cpuoct2020.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 bzip bzip2 1.0.6 -
2
运行在以下环境
系统 suse_12_SP4 bzip2 * Up to
(excluding)
1.0.6-30.5.1
3
运行在以下环境
系统 suse_12_SP4 bzip2 * Up to
(excluding)
1.0.6-30.5.1
4
运行在以下环境
系统 opensuse_Leap_15.1 bzip2 * Up to
(excluding)
1.0.6-lp151.5.3.1
5
运行在以下环境
系统 opensuse_Leap_15.0 bzip2 * Up to
(excluding)
1.0.6-lp150.4.3.1
6
运行在以下环境
系统 alpine_3.12 bzip2 * Up to
(excluding)
1.0.6-r5
7
运行在以下环境
系统 alpine_3.9 bzip2 * Up to
(excluding)
1.0.6-r5
8
运行在以下环境
系统 alpine_3.5 bzip2 * Up to
(excluding)
1.0.6-r5
9
运行在以下环境
系统 alpine_3.7 bzip2 * Up to
(excluding)
1.0.6-r5
10
运行在以下环境
系统 alpine_3.8 bzip2 * Up to
(excluding)
1.0.6-r5
11
运行在以下环境
系统 alpine_edge bzip2 * Up to
(excluding)
1.0.6-r5
12
运行在以下环境
系统 alpine_3.10 bzip2 * Up to
(excluding)
1.0.6-r5
13
运行在以下环境
系统 alpine_3.4 bzip2 * Up to
(excluding)
1.0.6-r5
14
运行在以下环境
系统 alpine_3.6 bzip2 * Up to
(excluding)
1.0.6-r5
15
运行在以下环境
系统 alpine_3.11 bzip2 * Up to
(excluding)
1.0.6-r5
16
运行在以下环境
系统 debian_8 bzip2 * Up to
(excluding)
1.0.6-7+deb8u1
17
运行在以下环境
系统 alpine_3.13 bzip2 * Up to
(excluding)
1.0.6-r5
18
运行在以下环境
系统 suse_12_SP4 bzip2 * Up to
(excluding)
1.0.6-30.5.1
19
运行在以下环境
系统 fedora_25 bzip2 * Up to
(excluding)
1.0.6-21.fc25
20
运行在以下环境
系统 fedora_24 bzip2 * Up to
(excluding)
1.0.6-21.fc24
21
运行在以下环境
系统 opensuse_Leap_15.1 bzip2 * Up to
(excluding)
1.0.6-lp151.5.3.1
22
运行在以下环境
系统 opensuse_Leap_15.0 bzip2 * Up to
(excluding)
1.0.6-lp150.4.3.1
23
运行在以下环境
系统 alpine_3.14 bzip2 * Up to
(excluding)
1.0.6-r5
24
运行在以下环境
系统 ubuntu_14.04 bzip2 * Up to
(excluding)
1.0.6-5ubuntu0.1~esm1
25
运行在以下环境
系统 ubuntu_16.04 bzip2 * Up to
(excluding)
1.0.6-8ubuntu0.1
26
运行在以下环境
系统 suse_12_SP4 bzip2 * Up to
(excluding)
1.0.6-30.5.1
27
运行在以下环境
系统 suse_12_SP4 bzip2 * Up to
(excluding)
1.0.6-30.5.1
28
运行在以下环境
系统 opensuse_Leap_15.1 bzip2 * Up to
(excluding)
1.0.6-lp151.5.3.1
29
运行在以下环境
系统 opensuse_Leap_15.0 bzip2 * Up to
(excluding)
1.0.6-lp150.4.3.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况