低危 LibTIFF 4.0.5 tif_zip.c ZIPEncode 越界读取漏洞

CVE编号

CVE-2016-3620

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-10-04
漏洞描述
Silicon Graphics LibTiff是一个读写TIFF文件的库。该库包含一些处理TIFF文件的命令行工具。 Silicon Graphics LibTiff的bmp2tiff工具中的tif_zip.c文件中的‘ZIPEncode’函数存在拒绝服务漏洞,允许攻击者利用带有‘-c lzw’参数的bmp图像,诱使应用解析,使应用程序崩溃。

解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
http://www.libtiff.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libtiff libtiff * Up to
(including)
4.0.6
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.0.6-3
运行在以下环境
系统 debian_7 tiff * Up to
(excluding)
4.0.2-6+deb7u7
运行在以下环境
系统 debian_8 tiff * Up to
(excluding)
4.0.3-12.3+deb8u10
运行在以下环境
系统 suse_11 libtiff3 * Up to
(excluding)
3.8.2-141.169.22
运行在以下环境
系统 suse_11_SP4 tiff * Up to
(excluding)
3.8.2-141.169.22.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况