低危 ImageMagick Studio ImageMagick任意文件移动漏洞

CVE编号

CVE-2016-3716

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2016-05-06
漏洞描述
ImageMagick Studio ImageMagick是美一套开源的图象处理软件。

ImageMagick Studio ImageMagick的MSL编码器中存在安全漏洞,允许远程攻击者构建恶意图片,上传并移动任意文件。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=29588
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * Up to
(including)
6.9.3-9
运行在以下环境
应用 imagemagick imagemagick 7.0.0-0 -
运行在以下环境
应用 imagemagick imagemagick 7.0.1-0 -
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.3.24-1
运行在以下环境
系统 redhat enterprise_linux_desktop 6.0 -
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_hpc_node 6.0 -
运行在以下环境
系统 redhat enterprise_linux_hpc_node 7.0 -
运行在以下环境
系统 redhat enterprise_linux_hpc_node_eus 7.2 -
运行在以下环境
系统 redhat enterprise_linux_server 6.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server_aus 7.2 -
运行在以下环境
系统 redhat enterprise_linux_server_eus 7.2 -
运行在以下环境
系统 redhat enterprise_linux_server_supplementary_eus 6.7z -
运行在以下环境
系统 redhat enterprise_linux_workstation 6.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 ImageMagick * Up to
(excluding)
0:6.7.2.7-4.el6_7
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-33
运行在以下环境
系统 ubuntu_12.04.5_lts imagemagick * Up to
(excluding)
8:6.6.9.7-5ubuntu3.4
运行在以下环境
系统 ubuntu_14.04.6_lts graphicsmagick * Up to
(excluding)
1.3.18-1ubuntu3.1
运行在以下环境
系统 ubuntu_16.04.7_lts graphicsmagick * Up to
(excluding)
1.3.23-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts graphicsmagick * Up to
(excluding)
1.3.24-1
运行在以下环境
系统 ubuntu_18.10 graphicsmagick * Up to
(excluding)
1.3.24-1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-264 权限、特权和访问控制
阿里云安全产品覆盖情况