低危 Google Go up to 1.5.3/1.6.0 crypto/dsa/dsa.go Verify 拒绝服务漏洞

CVE编号

CVE-2016-3959

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-24
漏洞描述
Google Go是美国谷歌(Google)公司的一种针对多处理器系统应用程序的编程进行了优化的编程语言。

Google Go 1.5.4之前版本和1.6.1之前1.6.x版本的crypto/dsa/dsa.go文件中的Verify函数存在拒绝服务漏洞,该漏洞源于程序未能正确检查传递到大型整数库中的参数。远程攻击者可借助使用HTTPS客户端证书或SSH服务器库的程序的公钥利用该漏洞造成拒绝服务(无限循环)。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://golang.org/cl/21533
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(including)
1.5
运行在以下环境
应用 golang go 1.6 -
运行在以下环境
系统 amazon linux_AMI golang * Up to
(excluding)
1.5.3-1.21.amzn1
运行在以下环境
系统 amazon_AMI golang * Up to
(excluding)
1.5.3-1.21.amzn1
运行在以下环境
系统 centos_7 golang * Up to
(excluding)
1.6.3-1.el7_2.1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 fedoraproject fedora 22 -
运行在以下环境
系统 fedoraproject fedora 23 -
运行在以下环境
系统 fedoraproject fedora 24 -
运行在以下环境
系统 fedora_22 golang * Up to
(excluding)
1.5.4-1.fc22
运行在以下环境
系统 fedora_23 golang * Up to
(excluding)
1.5.4-1.fc23
运行在以下环境
系统 fedora_24 golang * Up to
(excluding)
1.6.1-1.fc24
运行在以下环境
系统 fedora_EPEL_6 golang * Up to
(excluding)
1.7.1-1.el6
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse_Leap_42.1 golang * Up to
(excluding)
1.6.1-14.1
运行在以下环境
系统 redhat_7 golang * Up to
(excluding)
0:1.6.3-1.el7_2.1
运行在以下环境
系统 ubuntu_16.04.7_lts golang-1.6 * Up to
(excluding)
1.6.1-0ubuntu1
运行在以下环境
系统 ubuntu_16.04_lts golang-1.6 * Up to
(excluding)
1.6.1-0ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况