低危 PHP ‘mb_strcut()’函数拒绝服务漏洞

CVE编号

CVE-2016-4073

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-21
漏洞描述
PHP是一种开源的通用计算机脚本语言。

PHP ‘mb_strcut()’函数未能正确处理字符串格式化,允许远程攻击者可利用该漏洞提交特殊请求使应用程序崩溃。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugs.php.net/bug.php?id=71906
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
运行在以下环境
应用 php php 5.5.14 -
运行在以下环境
应用 php php 5.5.18 -
运行在以下环境
应用 php php 5.5.19 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.20 -
运行在以下环境
应用 php php 5.5.21 -
运行在以下环境
应用 php php 5.5.22 -
运行在以下环境
应用 php php 5.5.23 -
运行在以下环境
应用 php php 5.5.24 -
运行在以下环境
应用 php php 5.5.25 -
运行在以下环境
应用 php php 5.5.26 -
运行在以下环境
应用 php php 5.5.27 -
运行在以下环境
应用 php php 5.5.29 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.30 -
运行在以下环境
应用 php php 5.5.32 -
运行在以下环境
应用 php php 5.5.33 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
应用 php php 5.6.0 -
运行在以下环境
应用 php php 5.6.1 -
运行在以下环境
应用 php php 5.6.10 -
运行在以下环境
应用 php php 5.6.11 -
运行在以下环境
应用 php php 5.6.12 -
运行在以下环境
应用 php php 5.6.13 -
运行在以下环境
应用 php php 5.6.14 -
运行在以下环境
应用 php php 5.6.15 -
运行在以下环境
应用 php php 5.6.16 -
运行在以下环境
应用 php php 5.6.17 -
运行在以下环境
应用 php php 5.6.18 -
运行在以下环境
应用 php php 5.6.19 -
运行在以下环境
应用 php php 5.6.2 -
运行在以下环境
应用 php php 5.6.3 -
运行在以下环境
应用 php php 5.6.4 -
运行在以下环境
应用 php php 5.6.5 -
运行在以下环境
应用 php php 5.6.6 -
运行在以下环境
应用 php php 5.6.7 -
运行在以下环境
应用 php php 5.6.8 -
运行在以下环境
应用 php php 5.6.9 -
运行在以下环境
应用 php php 7.0.0 -
运行在以下环境
应用 php php 7.0.1 -
运行在以下环境
应用 php php 7.0.2 -
运行在以下环境
应用 php php 7.0.3 -
运行在以下环境
应用 php php 7.0.4 -
运行在以下环境
系统 amazon_AMI php5 * Up to
(excluding)
5.6.21-1.124.amzn1
运行在以下环境
系统 debian_7 php5 * Up to
(excluding)
5.4.45-0+deb7u3
运行在以下环境
系统 debian_8 php5 * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 opensuse_13.2 php5 * Up to
(excluding)
5.6.1-57.1
运行在以下环境
系统 opensuse_Leap_42.1 php5 * Up to
(excluding)
5.5.14-47.1
运行在以下环境
系统 suse_11_SP4 php5 * Up to
(excluding)
5.3.17-71.1
运行在以下环境
系统 ubuntu_14.04 php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.16
运行在以下环境
系统 ubuntu_16.04 php5 * Up to
(excluding)
7.0.4-7ubuntu2.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况