低危 nginx up to 1.11.0 ngx_files.c ngx_chain_to_iovec 拒绝服务漏洞

CVE编号

CVE-2016-4450

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-06-08
漏洞描述
Nginx是一款使用非常广泛的高性能web服务器。

Nginx保存客户端请求到临时文件的代码中存在空指针间接引用漏洞,畸形的请求可造成拒绝服务。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://nginx.org/en/download.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * From
(including)
1.3.9
Up to
(excluding)
1.10.1
运行在以下环境
应用 nginx nginx 1.11.0 -
运行在以下环境
系统 amazon linux_AMI nginx * Up to
(excluding)
1.8.1-3.27.amzn1
运行在以下环境
系统 amazon_AMI nginx * Up to
(excluding)
1.8.1-3.27.amzn1
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.10.1-1
运行在以下环境
系统 debian_8 nginx * Up to
(excluding)
1.6.2-5+deb8u1
运行在以下环境
系统 fedora_23 nginx * Up to
(excluding)
1.8.1-2.fc23
运行在以下环境
系统 fedora_24 nginx * Up to
(excluding)
1.10.1-1.fc24
运行在以下环境
系统 fedora_EPEL_5 nginx * Up to
(excluding)
1.10.1-1.el5
运行在以下环境
系统 fedora_EPEL_6 nginx * Up to
(excluding)
1.10.1-1.el6
运行在以下环境
系统 fedora_EPEL_7 nginx * Up to
(excluding)
1.6.3-9.el7
运行在以下环境
系统 opensuse_Leap_42.1 nginx * Up to
(excluding)
1.8.1-9.1
运行在以下环境
系统 opensuse_Leap_42.2 nginx * Up to
(excluding)
1.8.1-9.1
运行在以下环境
系统 ubuntu_14.04 nginx * Up to
(excluding)
1.4.6-1ubuntu3.5
运行在以下环境
系统 ubuntu_14.04.6_lts nginx * Up to
(excluding)
1.4.6-1ubuntu3.5
运行在以下环境
系统 ubuntu_14.04_lts nginx * Up to
(excluding)
1.4.6-1ubuntu3.5
运行在以下环境
系统 ubuntu_16.04 nginx * Up to
(excluding)
1.10.0-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts nginx * Up to
(excluding)
1.10.0-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04_lts nginx * Up to
(excluding)
1.10.0-0ubuntu0.16.04.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况