低危 Expat执行任意代码漏洞

CVE编号

CVE-2016-4472

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-07-01
漏洞描述
Expat是美国软件开发者吉姆-克拉克所研发的一个基于C语言的XML解析器库。

Expat中存在安全漏洞,远程攻击者可借助特制的XML数据利用该漏洞造成拒绝服务(崩溃)或执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://sourceforge.net/p/expat/code_git/ci/f0bec73b018caa07d3e75ec8dd967f3785d71bde
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat expat * Up to
(including)
2.1.1
运行在以下环境
系统 alpine_3.4 expat * Up to
(excluding)
2.1.1-r2
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.1.1-2
运行在以下环境
系统 debian_7 expat * Up to
(excluding)
2.1.0-1+deb7u3
运行在以下环境
系统 debian_8 expat * Up to
(excluding)
2.1.0-6+deb8u6
运行在以下环境
系统 fedora_22 expat * Up to
(excluding)
2.1.1-2.fc22
运行在以下环境
系统 fedora_23 expat * Up to
(excluding)
2.1.1-2.fc23
运行在以下环境
系统 fedora_24 expat * Up to
(excluding)
2.1.1-2.fc24
运行在以下环境
系统 suse_12 libpython3_4m1_0 * Up to
(excluding)
3.4.10-25.39
运行在以下环境
系统 suse_12_SP4 expat * Up to
(excluding)
3.4.10-25.39.3
运行在以下环境
系统 suse_12_SP5 expat * Up to
(excluding)
3.4.10-25.39.2
运行在以下环境
系统 ubuntu_12.04.5_lts expat * Up to
(excluding)
2.0.1-7.2ubuntu1.3
运行在以下环境
系统 ubuntu_14.04.6_lts expat * Up to
(excluding)
2.1.0-4ubuntu1.2
运行在以下环境
系统 ubuntu_16.04.7_lts expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts expat * Up to
(excluding)
2.1.1-1ubuntu1
运行在以下环境
系统 ubuntu_18.10 expat * Up to
(excluding)
2.1.1-1ubuntu1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况