低危 PHP不完全修复远程代码执行漏洞

CVE编号

CVE-2016-4473

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-06-09
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言支持多重语法、支持多数据库及操作系统和支持C、C++进行程序扩展等。

PHP 7.0.7版本和5.6.x版本中的/ext/phar/phar_object.c文件存在安全漏洞。远程攻击者可利用该漏洞执行任意代码。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugzilla.redhat.com/show_bug.cgi?id=1347772
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php 5.6.0 -
运行在以下环境
应用 php php 5.6.1 -
运行在以下环境
应用 php php 5.6.10 -
运行在以下环境
应用 php php 5.6.11 -
运行在以下环境
应用 php php 5.6.12 -
运行在以下环境
应用 php php 5.6.13 -
运行在以下环境
应用 php php 5.6.14 -
运行在以下环境
应用 php php 5.6.15 -
运行在以下环境
应用 php php 5.6.16 -
运行在以下环境
应用 php php 5.6.17 -
运行在以下环境
应用 php php 5.6.18 -
运行在以下环境
应用 php php 5.6.19 -
运行在以下环境
应用 php php 5.6.2 -
运行在以下环境
应用 php php 5.6.20 -
运行在以下环境
应用 php php 5.6.21 -
运行在以下环境
应用 php php 5.6.22 -
运行在以下环境
应用 php php 5.6.3 -
运行在以下环境
应用 php php 5.6.4 -
运行在以下环境
应用 php php 5.6.5 -
运行在以下环境
应用 php php 5.6.6 -
运行在以下环境
应用 php php 5.6.7 -
运行在以下环境
应用 php php 5.6.8 -
运行在以下环境
应用 php php 5.6.9 -
运行在以下环境
应用 php php 7.0.7 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.23+dfsg-0+deb8u1
运行在以下环境
系统 suse_12 apache2-mod_php7 * Up to
(excluding)
7.0.7-15
运行在以下环境
系统 ubuntu_12.04.5_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.24
运行在以下环境
系统 ubuntu_12.04_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.24
运行在以下环境
系统 ubuntu_14.04.6_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.19
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.19
运行在以下环境
系统 ubuntu_16.04.7_lts php7.0 * Up to
(excluding)
7.0.8-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04_lts php7.0 * Up to
(excluding)
7.0.8-0ubuntu0.16.04.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况