低危 Linux kernel rtnetlink信息泄露漏洞

CVE编号

CVE-2016-4486

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-23
漏洞描述
Linux kernel是一款开源的操作系统。

Linux kernel的rtnetlink未能初始化‘map’栈对象中的填充字节,允许本地攻击者可利用该漏洞获取内核信息。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://git.kernel.org/cgit/linux/kernel/git/davem/net.git/commit/?id=5f8e44741f9f216e33736ea4ec65ca9ac03036e6
参考链接
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5f8...
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00044.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00056.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00038.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00055.html
http://www.debian.org/security/2016/dsa-3607
http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.5.5
http://www.openwall.com/lists/oss-security/2016/05/04/27
http://www.securityfocus.com/bid/90051
http://www.ubuntu.com/usn/USN-2989-1
http://www.ubuntu.com/usn/USN-2996-1
http://www.ubuntu.com/usn/USN-2997-1
http://www.ubuntu.com/usn/USN-2998-1
http://www.ubuntu.com/usn/USN-3000-1
http://www.ubuntu.com/usn/USN-3001-1
http://www.ubuntu.com/usn/USN-3002-1
http://www.ubuntu.com/usn/USN-3003-1
http://www.ubuntu.com/usn/USN-3004-1
http://www.ubuntu.com/usn/USN-3005-1
http://www.ubuntu.com/usn/USN-3006-1
http://www.ubuntu.com/usn/USN-3007-1
https://bugzilla.redhat.com/show_bug.cgi?id=1333316
https://github.com/torvalds/linux/commit/5f8e44741f9f216e33736ea4ec65ca9ac03036e6
https://www.exploit-db.com/exploits/46006/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon linux_AMI linux * Up to
(excluding)
4.4.10-22.54.amzn1
运行在以下环境
系统 amazon_AMI kernel * Up to
(excluding)
4.4.10-22.54.amzn1
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.5.4-1
运行在以下环境
系统 debian_7 linux * Up to
(excluding)
3.2.81-1
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 fedora_22 kernel * Up to
(excluding)
4.4.9-200.fc22
运行在以下环境
系统 fedora_23 kernel * Up to
(excluding)
4.5.3-200.fc23
运行在以下环境
系统 fedora_24 kernel * Up to
(excluding)
4.5.4-300.fc24
运行在以下环境
系统 linux linux_kernel * Up to
(including)
4.5.4
运行在以下环境
系统 novell suse_linux_enterprise_debuginfo 11.0 -
运行在以下环境
系统 novell suse_linux_enterprise_desktop 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_live_patching 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_module_for_public_cloud 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_real_time_extension 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_server 11.0 -
运行在以下环境
系统 novell suse_linux_enterprise_server 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_software_development_kit 11.0 -
运行在以下环境
系统 novell suse_linux_enterprise_software_development_kit 12.0 -
运行在以下环境
系统 novell suse_linux_enterprise_workstation_extension 12.0 -
运行在以下环境
系统 opensuse_11.4 linux * Up to
(excluding)
3.0.101-105.1
运行在以下环境
系统 opensuse_13.1 linux * Up to
(excluding)
2.639-11.32.2
运行在以下环境
系统 opensuse_13.2 linux * Up to
(excluding)
2.20.2
运行在以下环境
系统 opensuse_Leap_42.1 linux * Up to
(excluding)
4.1.26-21.1
运行在以下环境
系统 sles_11_SP4 linux * Up to
(excluding)
3.0.101-77.1
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.4.21-69
运行在以下环境
系统 sles_12 linux * Up to
(excluding)
3.12.60-52.49.1
运行在以下环境
系统 sles_12_SP1 linux * Up to
(excluding)
3.12.62-60.62.1
运行在以下环境
系统 suse_11_SP4 linux * Up to
(excluding)
3.0.101-77.1
运行在以下环境
系统 suse_12 linux * Up to
(excluding)
3.12.60-52.49.1
运行在以下环境
系统 suse_12_SP1 linux * Up to
(excluding)
3.12.62-60.62.1
运行在以下环境
系统 ubuntu_12.04.5_lts linux * Up to
(excluding)
3.2.0-104.145
运行在以下环境
系统 ubuntu_12.04_lts linux * Up to
(excluding)
3.2.0-104.145
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
3.13.0-87.133
运行在以下环境
系统 ubuntu_14.04.6_lts linux * Up to
(excluding)
3.13.0-87.133
运行在以下环境
系统 ubuntu_14.04_lts linux * Up to
(excluding)
3.13.0-87.133
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.4.0-24.43
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.4.0-24.43
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-24.43
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况