低危 libgd内存泄露漏洞

CVE编号

CVE-2016-5116

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-08-07
漏洞描述
libgd(又名GD Graphics Library或libgd2)是美国软件开发者Thomas Boutell所研发的一个开源的用于动态创建图像的库,它支持创建图表、图形和缩略图等。

libgd的‘gdCtxPrintf’函数中存在内存泄露漏洞,该漏洞源于程序未检查‘vsnprintf’函数的返回值,PHP 5.5版本将输出指定的长度值。攻击者可利用该漏洞造成内存数据泄露。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://github.com/libgd/libgd/issues/211
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * Up to
(including)
2.2.1
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
运行在以下环境
应用 php php 5.5.14 -
运行在以下环境
应用 php php 5.5.18 -
运行在以下环境
应用 php php 5.5.19 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.20 -
运行在以下环境
应用 php php 5.5.21 -
运行在以下环境
应用 php php 5.5.22 -
运行在以下环境
应用 php php 5.5.23 -
运行在以下环境
应用 php php 5.5.24 -
运行在以下环境
应用 php php 5.5.25 -
运行在以下环境
应用 php php 5.5.26 -
运行在以下环境
应用 php php 5.5.27 -
运行在以下环境
应用 php php 5.5.28 -
运行在以下环境
应用 php php 5.5.29 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.30 -
运行在以下环境
应用 php php 5.5.31 -
运行在以下环境
应用 php php 5.5.32 -
运行在以下环境
应用 php php 5.5.33 -
运行在以下环境
应用 php php 5.5.34 -
运行在以下环境
应用 php php 5.5.35 -
运行在以下环境
应用 php php 5.5.37 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
系统 alpine_3.2 gd * Up to
(excluding)
2.2.1-r2
运行在以下环境
系统 alpine_3.3 gd * Up to
(excluding)
2.2.1-r2
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u3
运行在以下环境
系统 fedora_22 gd * Up to
(excluding)
2.1.1-4.fc22
运行在以下环境
系统 fedora_23 gd * Up to
(excluding)
2.1.1-6.fc23
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
2.2.1-1.fc24
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
2.1.0-7.8.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-10.1
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-12.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.2
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况