低危 GraphicsMagick和ImageMagick代码执行漏洞

CVE编号

CVE-2016-5118

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-06-11
漏洞描述
GraphicsMagick是一套简单的图像处理工具,该工具对图像提供尺寸调整、旋转、加亮等功能。ImageMagick是美国ImageMagick Studio公司的一套开源的图象处理软件,该软件可读取、转换、写入多种格式的图片。

GraphicsMagick和ImageMagick的‘popen()’函数中存在代码执行漏洞。攻击者可借助文件名利用该漏洞执行shell代码。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.graphicsmagick.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick * Up to
(including)
1.3.23
运行在以下环境
应用 suse linux_enterprise_debuginfo 11 -
运行在以下环境
应用 suse studio_onsite 1.3 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.3.24-1
运行在以下环境
系统 redhat_7 ImageMagick * Up to
(excluding)
0:6.7.8.9-15.el7_2
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-33
运行在以下环境
系统 ubuntu_12.04.5_lts imagemagick * Up to
(excluding)
8:6.6.9.7-5ubuntu3.4
运行在以下环境
系统 ubuntu_12.04_lts imagemagick * Up to
(excluding)
8:6.6.9.7-5ubuntu3.4
运行在以下环境
系统 ubuntu_14.04.6_lts graphicsmagick * Up to
(excluding)
1.3.18-1ubuntu3.1
运行在以下环境
系统 ubuntu_14.04_lts graphicsmagick * Up to
(excluding)
1.3.18-1ubuntu3.1
运行在以下环境
系统 ubuntu_16.04.7_lts graphicsmagick * Up to
(excluding)
1.3.23-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04_lts graphicsmagick * Up to
(excluding)
1.3.23-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts graphicsmagick * Up to
(excluding)
1.3.24-1
运行在以下环境
系统 ubuntu_18.04_lts graphicsmagick * Up to
(excluding)
1.3.24-1
运行在以下环境
系统 ubuntu_18.10 graphicsmagick * Up to
(excluding)
1.3.24-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-284 访问控制不恰当
阿里云安全产品覆盖情况