低危 expat XML Parser Exhaustion 拒绝服务漏洞

CVE编号

CVE-2016-5300

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-06-17
漏洞描述
Expat是一个基于C语言的XML解析器库,它采用了一个面向流的解析器。

Expat的XML解析器未能使用合适的熵进行哈希值初始化,允许远程攻击者可利用漏洞构建特殊的XML文档,诱使应用解析,可使应用程序崩溃。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://sourceforge.net/p/expat/code_git/ci/07cc2fcacf81b32b2e06aa918df51756525240c0/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat expat * Up to
(excluding)
2.2.0
运行在以下环境
系统 alpine_3.2 expat * Up to
(excluding)
2.2.0-r0
运行在以下环境
系统 alpine_3.3 expat * Up to
(excluding)
2.2.0-r0
运行在以下环境
系统 alpine_3.4 expat * Up to
(excluding)
2.2.0-r0
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.1.1-3
运行在以下环境
系统 debian_7 expat * Up to
(excluding)
2.1.0-1+deb7u4
运行在以下环境
系统 debian_8 expat * Up to
(excluding)
2.1.0-6+deb8u6
运行在以下环境
系统 fedora_22 expat * Up to
(excluding)
2.1.1-2.fc22
运行在以下环境
系统 fedora_23 expat * Up to
(excluding)
2.1.1-2.fc23
运行在以下环境
系统 fedora_24 expat * Up to
(excluding)
2.1.1-2.fc24
运行在以下环境
系统 google android 4.4.4 -
运行在以下环境
系统 google android 5.0.2 -
运行在以下环境
系统 google android 5.1.1 -
运行在以下环境
系统 google android 6.0 -
运行在以下环境
系统 google android 6.0.1 -
运行在以下环境
系统 opensuse_Leap_42.1 expat * Up to
(excluding)
2.1.0-19.1
运行在以下环境
系统 opensuse_Leap_42.2 expat * Up to
(excluding)
2.1.0-19.1
运行在以下环境
系统 sles_11_SP4 expat * Up to
(excluding)
2.0.1-88.41.1
运行在以下环境
系统 sles_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 sles_12_SP1 expat * Up to
(excluding)
2.1.0-20.2
运行在以下环境
系统 sles_12_SP2 expat * Up to
(excluding)
2.1.0-20.2
运行在以下环境
系统 suse_11_SP4 expat * Up to
(excluding)
2.0.1-88.41.1
运行在以下环境
系统 suse_12_SP1 expat * Up to
(excluding)
2.1.0-20.2
运行在以下环境
系统 suse_12_SP2 expat * Up to
(excluding)
2.1.0-20.2
运行在以下环境
系统 ubuntu_12.04_lts expat * Up to
(excluding)
2.0.1-7.2ubuntu1.4
运行在以下环境
系统 ubuntu_14.04 expat * Up to
(excluding)
2.1.0-4ubuntu1.3
运行在以下环境
系统 ubuntu_14.04_lts expat * Up to
(excluding)
2.1.0-4ubuntu1.3
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04_lts expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_18.04_lts expat * Up to
(excluding)
2.2.0-1
运行在以下环境
系统 ubuntu_18.10 expat * Up to
(excluding)
2.2.0-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况