低危 Apple macOS up to 10.12.3 Apache 拒绝服务漏洞

CVE编号

CVE-2016-5387

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-07-19
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)软件基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。

httpoxy是一组影响应用程序代码在CGI环境运行的漏洞。该漏洞主要存在于多个Web服务器、Web框架和编程语言中。可对HTTP头部的Proxy字段名变换为“HTTP_PROXY”,Value值不变,进而传递给对应的CGI执行;若CGI或脚本中使用对外请求的组件依赖的是“HTTP_PROXY”环境变量,就可能被污染。未经身份验证的远程攻击者利用漏洞可发起中间人攻击,或在服务器上启动任意主机的连接。

Apache HTTP Server存在httpoxy远程代理感染漏洞,该漏洞源于程序未能解决RFC 3875模式下的命名空间冲突。程序未能正确处理来自HTTP_PROXY环境变量中不可信客户端数据应用程序。允许远程攻击者通过精心设计的HTTP请求代理头重定向应用程序的出站HTTP流量到任意一个代理服务器。


解决建议
厂商提供了修复方案,请及时更新:
http://www.apache.org/security/asf-httpoxy-response.txt
参考链接
http://lists.opensuse.org/opensuse-updates/2016-07/msg00059.html
http://rhn.redhat.com/errata/RHSA-2016-1624.html
http://rhn.redhat.com/errata/RHSA-2016-1625.html
http://rhn.redhat.com/errata/RHSA-2016-1648.html
http://rhn.redhat.com/errata/RHSA-2016-1649.html
http://rhn.redhat.com/errata/RHSA-2016-1650.html
http://www.debian.org/security/2016/dsa-3623
http://www.kb.cert.org/vuls/id/797896
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
http://www.oracle.com/technetwork/topics/security/bulletinoct2016-3090566.html
http://www.oracle.com/technetwork/topics/security/linuxbulletinjul2016-3090544.html
http://www.securityfocus.com/bid/91816
http://www.securitytracker.com/id/1036330
http://www.ubuntu.com/usn/USN-3038-1
https://access.redhat.com/errata/RHSA-2016:1420
https://access.redhat.com/errata/RHSA-2016:1421
https://access.redhat.com/errata/RHSA-2016:1422
https://access.redhat.com/errata/RHSA-2016:1635
https://access.redhat.com/errata/RHSA-2016:1636
https://access.redhat.com/errata/RHSA-2016:1851
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr...
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_n...
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_n...
https://httpoxy.org/
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/8d63cb8e9100f28a99429b4328e4e7cebce861d5...
https://lists.apache.org/thread.html/f7f95ac1cd9895db2714fa3ebaa0b94d0c6df360...
https://lists.apache.org/thread.html/r04e89e873d54116a0635ef2f7061c15acc5ed27...
https://lists.apache.org/thread.html/r476d175be0aaf4a17680ef98c5153b4d336eaef...
https://lists.apache.org/thread.html/r57608dc51b79102f3952ae06f54d5277b649c86...
https://lists.apache.org/thread.html/r75cbe9ea3e2114e4271bbeca7aff96117b50c1b...
https://lists.apache.org/thread.html/r9ea3538f229874c80a10af473856a81fbf5f694...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rad01d817195e6cc871cb1d73b207ca326379a20...
https://lists.apache.org/thread.html/rb14daf9cc4e28d18cdc15d6a6ca74e565672fab...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rcc44594d4d6579b90deccd4536b5d31f099ef56...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/rdca61ae990660bacb682295f2a09d34612b7bb5...
https://lists.apache.org/thread.html/re1e3a24664d35bcd0a0e793e0b5fc6ca6c107f9...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfbaf647d52c1cb843e726a0933f156366a806ce...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://security.gentoo.org/glsa/201701-36
https://support.apple.com/HT208221
https://www.apache.org/security/asf-httpoxy-response.txt
https://www.tenable.com/security/tns-2017-04
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * Up to
(including)
2.4.23
运行在以下环境
应用 hp system_management_homepage * Up to
(including)
7.5.5.0
运行在以下环境
应用 redhat jboss_web_server 2.1.0 -
运行在以下环境
系统 alpine_3.4 apache2 * Up to
(excluding)
2.4.23-r1
运行在以下环境
系统 amazon_AMI apache2 * Up to
(excluding)
2.2.31-1.8.amzn1
运行在以下环境
系统 centos_5 apache2 * Up to
(excluding)
2.2.3-92.el5.centos
运行在以下环境
系统 centos_7 apache2 * Up to
(excluding)
2.4.6-40.el7.centos.4
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.4.23-2
运行在以下环境
系统 debian_7 apache2 * Up to
(excluding)
2.2.22-13+deb7u7
运行在以下环境
系统 debian_8 apache2 * Up to
(excluding)
2.4.10-10+deb8u5
运行在以下环境
系统 fedoraproject fedora 23 -
运行在以下环境
系统 fedoraproject fedora 24 -
运行在以下环境
系统 fedora_23 apache2 * Up to
(excluding)
0.22-1.fc23
运行在以下环境
系统 fedora_24 apache2 * Up to
(excluding)
0.22-1.fc24
运行在以下环境
系统 opensuse_Leap_42.1 apache2 * Up to
(excluding)
2.3.9-7.1
运行在以下环境
系统 oracle linux 5.0 -
运行在以下环境
系统 oracle linux 6 -
运行在以下环境
系统 oracle linux 7 -
运行在以下环境
系统 oracle solaris 11.3 -
运行在以下环境
系统 oracle_5 apache2 * Up to
(excluding)
2.2.15-54.0.1.el6_8
运行在以下环境
系统 oracle_6 apache2 * Up to
(excluding)
2.2.15-54.0.1.el6_8
运行在以下环境
系统 oracle_7 apache2 * Up to
(excluding)
2.4.6-40.0.1.el7_2.4
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat_6 httpd * Up to
(excluding)
0:2.2.3-92.el5_11
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-40.el7_2.4
运行在以下环境
系统 sles_12 apache2 * Up to
(excluding)
2.4.23-14
运行在以下环境
系统 suse_11_SP4 apache2 * Up to
(excluding)
2.2.12-64.1
运行在以下环境
系统 suse_12_SP1 apache2 * Up to
(excluding)
2.4.16-7.1
运行在以下环境
系统 ubuntu_12.04_lts apache2 * Up to
(excluding)
2.2.22-1ubuntu1.11
运行在以下环境
系统 ubuntu_14.04 apache2 * Up to
(excluding)
2.4.7-1ubuntu4.13
运行在以下环境
系统 ubuntu_14.04_lts apache2 * Up to
(excluding)
2.4.7-1ubuntu4.13
运行在以下环境
系统 ubuntu_16.04 apache2 * Up to
(excluding)
2.4.18-2ubuntu3.1
运行在以下环境
系统 ubuntu_16.04_lts apache2 * Up to
(excluding)
2.4.18-2ubuntu3.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-284 访问控制不恰当
阿里云安全产品覆盖情况