低危 Haxx libcurl内存错误引用漏洞

CVE编号

CVE-2016-5421

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-08-11
漏洞描述
Haxx libcurl是瑞典Haxx公司的一个免费、开源的客户端URL传输库。

Haxx libcurl 7.50.1之前的版本中存在内存错误引用漏洞。攻击者可利用该漏洞控制被使用的连接。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://curl.haxx.se/docs/adv_20160803C.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx libcurl * Up to
(including)
7.50.0
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.50.1
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.50.1
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 alpine_3.2 curl * Up to
(excluding)
7.49.1-r1
运行在以下环境
系统 alpine_3.3 curl * Up to
(excluding)
7.49.1-r1
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.50.1
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.50.1
运行在以下环境
系统 alpine_3.8 curl * Up to
(excluding)
7.50.1
运行在以下环境
系统 alpine_3.9 curl * Up to
(excluding)
7.50.1
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.50.1-r0
运行在以下环境
系统 amazon linux_AMI curl * Up to
(excluding)
7.40.0-8.59.amzn1
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.40.0-8.59.amzn1
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
7.50.1-1
运行在以下环境
系统 debian_8 curl * Up to
(excluding)
7.38.0-4+deb8u2
运行在以下环境
系统 fedoraproject fedora 23 -
运行在以下环境
系统 fedoraproject fedora 24 -
运行在以下环境
系统 fedora_23 curl * Up to
(excluding)
7.43.0-8.fc23
运行在以下环境
系统 fedora_24 curl * Up to
(excluding)
7.47.1-6.fc24
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_13.2 curl * Up to
(excluding)
7.42.1-25.1
运行在以下环境
系统 opensuse_Leap_42.1 curl * Up to
(excluding)
7.37.0-13.1
运行在以下环境
系统 sles_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 sles_12_SP1 curl * Up to
(excluding)
7.37.0-28.1
运行在以下环境
系统 suse_12_SP1 curl * Up to
(excluding)
7.37.0-28.1
运行在以下环境
系统 ubuntu_14.04 curl * Up to
(excluding)
7.35.0-1ubuntu2.8
运行在以下环境
系统 ubuntu_14.04_lts curl * Up to
(excluding)
7.35.0-1ubuntu2.8
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.1
运行在以下环境
系统 ubuntu_16.04_lts curl * Up to
(excluding)
7.47.0-1ubuntu2.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况