Puppet Enterprise和Puppet Agent代码执行漏洞

CVE编号

CVE-2016-5714

利用情况

暂无

补丁情况

N/A

披露时间

2017-10-19
漏洞描述
Puppet Enterprise和Puppet Agent都是美国Puppet实验室的产品。Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,Puppet Enterprise是一个企业版;Puppet Agent是一套客户端工具。

Puppet Enterprise 2015.3.3版本、2016.4.0之前的2016.x版本和Puppet Agent 1.3.6版本至1.7.0版本中存在安全漏洞。远程攻击者可利用该漏洞绕过主机白名单保护机制,在Puppet节点上执行任意代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://puppet.com/security/cve/pxp-agent-oct-2016
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise 2015.3.3 -
运行在以下环境
应用 puppet puppet_enterprise 2016.1.1 -
运行在以下环境
应用 puppet puppet_enterprise 2016.1.2 -
运行在以下环境
应用 puppet puppet_enterprise 2016.2.0 -
运行在以下环境
应用 puppet puppet_enterprise 2016.2.1 -
运行在以下环境
应用 puppetlabs puppet_agent 1.3.6 -
运行在以下环境
应用 puppetlabs puppet_agent 1.4.0 -
运行在以下环境
应用 puppetlabs puppet_agent 1.4.1 -
运行在以下环境
应用 puppetlabs puppet_agent 1.4.2 -
运行在以下环境
应用 puppetlabs puppet_agent 1.5.0 -
运行在以下环境
应用 puppetlabs puppet_agent 1.5.1 -
运行在以下环境
应用 puppetlabs puppet_agent 1.5.2 -
运行在以下环境
应用 puppetlabs puppet_agent 1.5.3 -
运行在以下环境
应用 puppetlabs puppet_agent 1.6.0 -
运行在以下环境
应用 puppetlabs puppet_agent 1.6.1 -
运行在以下环境
应用 puppetlabs puppet_agent 1.6.2 -
运行在以下环境
应用 puppetlabs puppet_agent 1.7.0 -
CVSS3评分
7.2
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-284 访问控制不恰当
阿里云安全产品覆盖情况